a library of vue components used by mapping applications

Last update: Apr 21, 2022

phila-vue-mapping (@phila/vue-mapping in npmjs.com)

phila-vue-mapping is a library of Vue components that can be used in mapping apps which use Vue.js and Vuex. It includes many mapping components such as Maps, ESRI WebMaps, and Cyclomedia Widgets, etc.

To Include The Components In Your App

  • in a bundled app, use npm:

    npm install @phila/vue-mapping

  • in an html file, use the CDN:

    <script src="//unpkg.com/@phila/[email protected]/dist/phila-vue-mapping.js"></script>

Usage

Check out the wiki for usage documentation.

Release Notes

3.0.1 - 8/18/2021

  • includes both mapbox and maplibre

3.0.0 - 7/26/2021

  • requires using npm for all package commands

2.2.12 - 7/15/2021

  • locks esri-leaflet version on 2.3.1

2.2.11 - 7/12/2021

  • fixes a bug with the position of the cyclomedia popout button for property-data-explorer

2.2.10 - 10/27/2020

  • uses github actions to push to npmjs

2.2.9 - 10/6/2020

  • ran yarn upgrades

2.2.8 - 10/5/2020

  • fixes bug with popout of cyclomedia and pictometry

2.2.7 - 9/18/2020

  • makes changes to map address input

2.2.6 - 9/18/2020

  • Adds control corner for bottom left for layerboard

2.2.5 - 9/17/2020

  • uses new commit of esri-leaflet-legend that adds space between symbols and labels

2.2.4 - 9/16/2020

  • removes nextTick from leaflet/Map.vue to make layerboard work

2.2.3 - 9/15/2020

  • fixes z-index of map address input for mapboard

2.2.2 - 9/4/2020

  • changes for WAVE for atlas.phila.gov

2.2.1 - 8/28/2020

  • fixes overlay legends for showing circles

2.2.0 - 8/28/2020

  • works with pvd that removes all leaflet imports

2.1.18 - 7/30/2020

  • fixes bug in mapbox/RasterLayer.vue for viewerboard

2.1.17 - 7/30/2020

  • allows moving legends to right side
  • changes css for moving measure tool to bottom right corner

2.1.16 - 7/30/2020

  • allows moving distance measure tool to right side

2.1.15 - 7/30/2020

2.1.14 - 7/29/2020

  • small fix for year dropdown in mapbox

2.1.13 - 7/29/2020

  • fixes more small bugs for releasing mapboard with a mapbox map

2.1.12 - 7/20/2020

  • all commits for using mapbox in mapboard

2.1.11 - 6/25/2020

  • fixes yarn lock for release

2.1.10 - 6/25/2020

  • fixes circlemarkers size in pinboard

2.1.9 - 6/23/2020

  • adds dependency leaflet-shape-markers

2.1.8 - 6/17/2020

  • fixes bug with font awesome marker placement in mapbox map

2.1.7 - 6/16/2020

  • adds FontAwesomeMarker.vue to mapbox section

2.1.6 - 6/14/2020

  • improvements in mapbox files for making vue work better, adding more diverse mapbox styles.

2.1.5 - 6/9/2020

  • improvements in mapbox files for basemaps, circlemarkers, etc.

2.1.4 - 5/27/2020

  • upgrades packages

2.1.3 - 5/7/2020

  • changes for popup order in layerboard

2.1.2 - 5/6/2020

  • changes to pictometry widget

2.1.1 - 5/5/2020

  • fixes problems with pushing to npm

2.1.0 - 5/5/2020

  • merges changes for use in pinboard and viewerboard

2.0.10 - 4/1/2020

  • fixes css for rendering map and cyclomedia in property data explorer

2.0.9 - 2/6/2020

2.0.8 - 2/6/2020

  • fixes pictometry popout button

2.0.7 - 2/6/2020

  • lints files for release

2.0.6 - 2/6/2020

  • fixes for viewerboard basemap toggle

2.0.5 - 1/31/2020

  • pushes again after linting project

2.0.4 - 1/31/2020

  • changes to make new destination work

2.0.3 - 1/31/2020

  • uses major updates to cyclomedia
  • pushes to @phila/vue-mapping instead of @philly/vue-mapping

2.0.2 - 12/30/2019

2.0.1 - 12/19/2019

2.0.0 - 12/17/2019

1.0.47 - 10/23/2019

  • correctly fixes date-fns

1.0.46 - 10/23/2019

  • attempt to fix date-fns

1.0.45 - 10/23/2019

  • you have to use the following with this:

    "@vue/cli-plugin-babel": "^4.0.5", "@vue/cli-plugin-eslint": "^4.0.5", "@vue/cli-service": "^4.0.5",

1.0.44 - 10/22/2019

  • updates from dependabot

1.0.43 - 10/17/2019

  • adds linting, fixes VectorMarker by moving changes from update lifecycle hook to a watch

1.0.42 - 10/9/2019

  • Uses update to L.esri.Webmap to add datetime to popups

1.0.41 - 10/7/2019

  • Monthly package upgrades, merges in all changes to work with pvd upgrade

1.0.40 - 9/24/2019

  • Changes for adapting to Cyclomedia 19.12

1.0.39 - 9/23/2019

  • Changes for adapting to Cyclomedia 19.12

1.0.38 - 9/23/2019

  • Changes for adapting to Cyclomedia 19.12

1.0.37 - 9/6/2019

  • Adds to Polyline.vue to fix style changes

1.0.36 - 9/6/2019

  • Monthly package upgrades

1.0.35 - 8/9/2019

  • Adds border to address search

1.0.34 - 8/9/2019

  • Monthly package upgrades

1.0.33 - 7/11/2019

  • Upgrades lodash-es and lodash.defaultsdeep

1.0.32 - 6/20/2019

  • changes for Pinboard

1.0.31 - 6/2/2019

  • Uses axios 0.19.0 to fix security bug

1.0.30 - 5/30/2019

  • Adds components/OverlaySelectControl.vue for toggling between two years of data in CleanPhl.
  • Changes made over initial development of resource finder.

GitHub

https://github.com/CityOfPhiladelphia/phila-vue-mapping/
Comments
  • 1. Bump websocket-extensions from 0.1.3 to 0.1.4

    Bumps websocket-extensions from 0.1.3 to 0.1.4.

    Changelog

    Sourced from websocket-extensions's changelog.

    0.1.4 / 2020-06-02

    • Remove a ReDoS vulnerability in the header parser (CVE-2020-7662, reported by Robert McLaughlin)
    • Change license from MIT to Apache 2.0
    Commits
    • 8efd0cd Bump version to 0.1.4
    • 3dad4ad Remove ReDoS vulnerability in the Sec-WebSocket-Extensions header parser
    • 4a76c75 Add Node versions 13 and 14 on Travis
    • 44a677a Formatting change: {...} should have spaces inside the braces
    • f6c50ab Let npm reformat package.json
    • 2d211f3 Change markdown formatting of docs.
    • 0b62083 Update Travis target versions.
    • 729a465 Switch license to Apache 2.0.
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2020-06-06 15:33
  • 2. Bump @vue/cli-service from 3.11.0 to 4.0.4

    Bumps @vue/cli-service from 3.11.0 to 4.0.4.

    Release notes

    Sourced from @vue/cli-service's releases.

    v4.0.4

    We've also released v3.12.1 to address the router plugin issue in a different way. See the release notes for more explanation.

    :bug: Bug Fix

    • @vue/cli-service
      • #4711 fix: fix a typo that caused router failed to install in CLI 3.x (@​sodatea)

    :memo: Documentation

    Committers: 2

    v4.0.3

    :bug: Bug Fix

    • @vue/cli-ui, @vue/cli
    • @vue/cli-service
      • #4696 fix: allow v3 cli to invoke vuex & router plugin from inside cli-service v4 (@​sodatea)
    • @vue/cli-plugin-eslint, @vue/cli-plugin-typescript, @vue/cli-ui

    Committers: 1

    v4.0.2

    :bug: Bug Fix

    • @vue/cli-service
      • #4693 fix: add a compatibility layer for router & vuex for CLI v3 & CLI UI (@​sodatea)

    Committers: 1

    v4.0.1

    :bug: Bug Fix

    • @vue/cli-plugin-eslint, @vue/cli-plugin-router, @vue/cli-plugin-vuex

    v4.0.0

    We're happy to announce the release of Vue CLI version 4!

    This major version bump is focused on necessary version bumps of underlying tools, better default setups, and other fine-tunings required for long-term maintenance.

    We expect a smooth migration experience for most users.

    You can view the full migration guide at https://cli.vuejs.org/migrating-from-v3/


    ... (truncated)
    Changelog

    Sourced from @vue/cli-service's changelog.

    4.0.4 (2019-10-18)

    :bug: Bug Fix

    • @vue/cli-service
      • #4711 fix: fix a typo that caused router failed to install in older versions (@​sodatea)

    :memo: Documentation

    Committers: 2

    4.0.3 (2019-10-17)

    :bug: Bug Fix

    • @vue/cli-ui, @vue/cli
    • @vue/cli-service
      • #4696 fix: allow v3 cli to invoke vuex & router plugin from inside cli-service (@​sodatea)
    • @vue/cli-plugin-eslint, @vue/cli-plugin-typescript, @vue/cli-ui

    Committers: 1

    4.0.2 (2019-10-17)

    :bug: Bug Fix

    • @vue/cli-service
      • #4693 fix: add a compatibility layer for router & vuex for CLI v3 (@​sodatea)

    Committers: 1

    4.0.1 (2019-10-16)

    :bug: Bug Fix

    • @vue/cli-plugin-eslint, @vue/cli-plugin-router, @vue/cli-plugin-vuex, @vue/cli-service-global, @vue/cli-ui-addon-webpack, @vue/cli-ui-addon-widgets, @vue/cli-ui, @vue/cli

    4.0.0 (2019-10-16)

    ... (truncated)
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Note: This repo was added to Dependabot recently, so you'll receive a maximum of 5 PRs for your first few update runs. Once an update run creates fewer than 5 PRs we'll remove that limit.

    You can always request more updates by clicking Bump now in your Dependabot dashboard.

    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
    • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

    Additionally, you can set the following in your Dependabot dashboard:

    • Update frequency (including time of day and day of week)
    • Pull request limits (per update run and/or open at any time)
    • Out-of-range updates (receive only lockfile updates, if desired)
    • Security updates (receive only security updates, if desired)
    Reviewed by dependabot-preview[bot] at 2019-10-20 18:23
  • 3. Bump jquery from 3.4.1 to 3.5.0

    Bumps jquery from 3.4.1 to 3.5.0.

    Commits
    • 7a0a850 3.5.0
    • 8570a08 Release: Update AUTHORS.txt
    • da3dd85 Ajax: Do not execute scripts for unsuccessful HTTP responses
    • 065143c Ajax: Overwrite s.contentType with content-type header value, if any
    • 1a4f10d Tests: Blacklist one focusin test in IE
    • 9e15d6b Event: Use only one focusin/out handler per matching window & document
    • 966a709 Manipulation: Skip the select wrapper for <option> outside of IE 9
    • 1d61fd9 Manipulation: Make jQuery.htmlPrefilter an identity function
    • 04bf577 Selector: Update Sizzle from 2.3.4 to 2.3.5
    • 7506c9c Build: Resolve Travis config warnings
    • Additional commits viewable in compare view
    Maintainer changes

    This version was pushed to npm by mgol, a new releaser for jquery since your current version.


    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2020-04-30 03:43
  • 4. Bump acorn from 5.7.3 to 5.7.4

    Bumps acorn from 5.7.3 to 5.7.4.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2020-03-13 23:33
  • 5. Bump @vue/cli-plugin-babel from 3.11.0 to 4.0.5

    Bumps @vue/cli-plugin-babel from 3.11.0 to 4.0.5.

    Release notes

    Sourced from @vue/cli-plugin-babel's releases.

    v4.0.5

    :bug: Bug Fix

    • @vue/cli
    • @vue/cli-plugin-eslint
      • #4740 fix: autofix code style after scaffolding on older versions of cli (@​sodatea)
      • #4728 fix: fix eslint not found error in vue serve command (@​sodatea)
    • @vue/cli-ui
      • #4739 fix: "add router" button should not require prompt in terminal (@​sodatea)
      • #4724 fix: fix latest version check always displaying "0.1.0" (@​sodatea)

    :memo: Documentation

    :house: Internal

    • @vue/babel-preset-app, @vue/cli-plugin-babel, @vue/cli-plugin-e2e-cypress, @vue/cli-plugin-e2e-nightwatch, @vue/cli-plugin-eslint, @vue/cli-plugin-router, @vue/cli-plugin-typescript, @vue/cli-plugin-unit-jest, @vue/cli-plugin-unit-mocha, @vue/cli-service-global, @vue/cli-service, @vue/cli-test-utils, @vue/cli-ui-addon-webpack, @vue/cli-ui-addon-widgets, @vue/cli-ui, @vue/cli

    Committers: 2

    v4.0.4

    We've also released v3.12.1 to address the router plugin issue in a different way. See the release notes for more explanation.

    :bug: Bug Fix

    • @vue/cli-service
      • #4711 fix: fix a typo that caused router failed to install in CLI 3.x (@​sodatea)

    :memo: Documentation

    Committers: 2

    v4.0.3

    :bug: Bug Fix

    • @vue/cli-ui, @vue/cli
    • @vue/cli-service
      • #4696 fix: allow v3 cli to invoke vuex & router plugin from inside cli-service v4 (@​sodatea)
    • @vue/cli-plugin-eslint, @vue/cli-plugin-typescript, @vue/cli-ui

    Committers: 1

    v4.0.2

    ... (truncated)
    Changelog

    Sourced from @vue/cli-plugin-babel's changelog.

    4.0.5 (2019-10-22)

    :bug: Bug Fix

    • @vue/cli
    • @vue/cli-plugin-eslint
      • #4740 fix(eslint): autofix code style after scaffolding on older versions of cli (@​sodatea)
      • #4728 fix: fix eslint not found error in vue serve command (@​sodatea)
    • @vue/cli-ui
      • #4739 fix(ui): "add router" button should not require prompt in terminal (@​sodatea)
      • #4724 fix(ui): fix latest version check always displaying "0.1.0" (@​sodatea)

    :memo: Documentation

    :house: Internal

    • @vue/babel-preset-app, @vue/cli-plugin-babel, @vue/cli-plugin-e2e-cypress, @vue/cli-plugin-e2e-nightwatch, @vue/cli-plugin-eslint, @vue/cli-plugin-router, @vue/cli-plugin-typescript, @vue/cli-plugin-unit-jest, @vue/cli-plugin-unit-mocha, @vue/cli-service-global, @vue/cli-service, @vue/cli-test-utils, @vue/cli-ui-addon-webpack, @vue/cli-ui-addon-widgets, @vue/cli-ui, @vue/cli

    Committers: 2

    4.0.4 (2019-10-18)

    :bug: Bug Fix

    • @vue/cli-service
      • #4711 fix: fix a typo that caused router failed to install in older versions (@​sodatea)

    :memo: Documentation

    Committers: 2

    4.0.3 (2019-10-17)

    :bug: Bug Fix

    • @vue/cli-ui, @vue/cli
    • @vue/cli-service
      • #4696 fix: allow v3 cli to invoke vuex & router plugin from inside cli-service (@​sodatea)
    • @vue/cli-plugin-eslint, @vue/cli-plugin-typescript, @vue/cli-ui
    ... (truncated)
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
    • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

    Additionally, you can set the following in your Dependabot dashboard:

    • Update frequency (including time of day and day of week)
    • Pull request limits (per update run and/or open at any time)
    • Out-of-range updates (receive only lockfile updates, if desired)
    • Security updates (receive only security updates, if desired)
    Reviewed by dependabot-preview[bot] at 2019-10-22 14:29
  • 6. Bump @vue/cli-service from 3.11.0 to 4.0.5

    Bumps @vue/cli-service from 3.11.0 to 4.0.5.

    Release notes

    Sourced from @vue/cli-service's releases.

    v4.0.5

    :bug: Bug Fix

    • @vue/cli
    • @vue/cli-plugin-eslint
      • #4740 fix: autofix code style after scaffolding on older versions of cli (@​sodatea)
      • #4728 fix: fix eslint not found error in vue serve command (@​sodatea)
    • @vue/cli-ui
      • #4739 fix: "add router" button should not require prompt in terminal (@​sodatea)
      • #4724 fix: fix latest version check always displaying "0.1.0" (@​sodatea)

    :memo: Documentation

    :house: Internal

    • @vue/babel-preset-app, @vue/cli-plugin-babel, @vue/cli-plugin-e2e-cypress, @vue/cli-plugin-e2e-nightwatch, @vue/cli-plugin-eslint, @vue/cli-plugin-router, @vue/cli-plugin-typescript, @vue/cli-plugin-unit-jest, @vue/cli-plugin-unit-mocha, @vue/cli-service-global, @vue/cli-service, @vue/cli-test-utils, @vue/cli-ui-addon-webpack, @vue/cli-ui-addon-widgets, @vue/cli-ui, @vue/cli

    Committers: 2

    v4.0.4

    We've also released v3.12.1 to address the router plugin issue in a different way. See the release notes for more explanation.

    :bug: Bug Fix

    • @vue/cli-service
      • #4711 fix: fix a typo that caused router failed to install in CLI 3.x (@​sodatea)

    :memo: Documentation

    Committers: 2

    v4.0.3

    :bug: Bug Fix

    • @vue/cli-ui, @vue/cli
    • @vue/cli-service
      • #4696 fix: allow v3 cli to invoke vuex & router plugin from inside cli-service v4 (@​sodatea)
    • @vue/cli-plugin-eslint, @vue/cli-plugin-typescript, @vue/cli-ui

    Committers: 1

    v4.0.2

    ... (truncated)
    Changelog

    Sourced from @vue/cli-service's changelog.

    4.0.5 (2019-10-22)

    :bug: Bug Fix

    • @vue/cli
    • @vue/cli-plugin-eslint
      • #4740 fix(eslint): autofix code style after scaffolding on older versions of cli (@​sodatea)
      • #4728 fix: fix eslint not found error in vue serve command (@​sodatea)
    • @vue/cli-ui
      • #4739 fix(ui): "add router" button should not require prompt in terminal (@​sodatea)
      • #4724 fix(ui): fix latest version check always displaying "0.1.0" (@​sodatea)

    :memo: Documentation

    :house: Internal

    • @vue/babel-preset-app, @vue/cli-plugin-babel, @vue/cli-plugin-e2e-cypress, @vue/cli-plugin-e2e-nightwatch, @vue/cli-plugin-eslint, @vue/cli-plugin-router, @vue/cli-plugin-typescript, @vue/cli-plugin-unit-jest, @vue/cli-plugin-unit-mocha, @vue/cli-service-global, @vue/cli-service, @vue/cli-test-utils, @vue/cli-ui-addon-webpack, @vue/cli-ui-addon-widgets, @vue/cli-ui, @vue/cli

    Committers: 2

    4.0.4 (2019-10-18)

    :bug: Bug Fix

    • @vue/cli-service
      • #4711 fix: fix a typo that caused router failed to install in older versions (@​sodatea)

    :memo: Documentation

    Committers: 2

    4.0.3 (2019-10-17)

    :bug: Bug Fix

    • @vue/cli-ui, @vue/cli
    • @vue/cli-service
      • #4696 fix: allow v3 cli to invoke vuex & router plugin from inside cli-service (@​sodatea)
    • @vue/cli-plugin-eslint, @vue/cli-plugin-typescript, @vue/cli-ui
    ... (truncated)
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
    • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

    Additionally, you can set the following in your Dependabot dashboard:

    • Update frequency (including time of day and day of week)
    • Pull request limits (per update run and/or open at any time)
    • Out-of-range updates (receive only lockfile updates, if desired)
    • Security updates (receive only security updates, if desired)
    Reviewed by dependabot-preview[bot] at 2019-10-22 14:29
  • 7. Bump @vue/cli-plugin-babel from 3.11.0 to 4.0.4

    Bumps @vue/cli-plugin-babel from 3.11.0 to 4.0.4.

    Release notes

    Sourced from @vue/cli-plugin-babel's releases.

    v4.0.4

    We've also released v3.12.1 to address the router plugin issue in a different way. See the release notes for more explanation.

    :bug: Bug Fix

    • @vue/cli-service
      • #4711 fix: fix a typo that caused router failed to install in CLI 3.x (@​sodatea)

    :memo: Documentation

    Committers: 2

    v4.0.3

    :bug: Bug Fix

    • @vue/cli-ui, @vue/cli
    • @vue/cli-service
      • #4696 fix: allow v3 cli to invoke vuex & router plugin from inside cli-service v4 (@​sodatea)
    • @vue/cli-plugin-eslint, @vue/cli-plugin-typescript, @vue/cli-ui

    Committers: 1

    v4.0.2

    :bug: Bug Fix

    • @vue/cli-service
      • #4693 fix: add a compatibility layer for router & vuex for CLI v3 & CLI UI (@​sodatea)

    Committers: 1

    v4.0.1

    :bug: Bug Fix

    • @vue/cli-plugin-eslint, @vue/cli-plugin-router, @vue/cli-plugin-vuex

    v4.0.0

    We're happy to announce the release of Vue CLI version 4!

    This major version bump is focused on necessary version bumps of underlying tools, better default setups, and other fine-tunings required for long-term maintenance.

    We expect a smooth migration experience for most users.

    You can view the full migration guide at https://cli.vuejs.org/migrating-from-v3/


    ... (truncated)
    Changelog

    Sourced from @vue/cli-plugin-babel's changelog.

    4.0.4 (2019-10-18)

    :bug: Bug Fix

    • @vue/cli-service
      • #4711 fix: fix a typo that caused router failed to install in older versions (@​sodatea)

    :memo: Documentation

    Committers: 2

    4.0.3 (2019-10-17)

    :bug: Bug Fix

    • @vue/cli-ui, @vue/cli
    • @vue/cli-service
      • #4696 fix: allow v3 cli to invoke vuex & router plugin from inside cli-service (@​sodatea)
    • @vue/cli-plugin-eslint, @vue/cli-plugin-typescript, @vue/cli-ui

    Committers: 1

    4.0.2 (2019-10-17)

    :bug: Bug Fix

    • @vue/cli-service
      • #4693 fix: add a compatibility layer for router & vuex for CLI v3 (@​sodatea)

    Committers: 1

    4.0.1 (2019-10-16)

    :bug: Bug Fix

    • @vue/cli-plugin-eslint, @vue/cli-plugin-router, @vue/cli-plugin-vuex, @vue/cli-service-global, @vue/cli-ui-addon-webpack, @vue/cli-ui-addon-widgets, @vue/cli-ui, @vue/cli

    4.0.0 (2019-10-16)

    ... (truncated)
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Note: This repo was added to Dependabot recently, so you'll receive a maximum of 5 PRs for your first few update runs. Once an update run creates fewer than 5 PRs we'll remove that limit.

    You can always request more updates by clicking Bump now in your Dependabot dashboard.

    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
    • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

    Additionally, you can set the following in your Dependabot dashboard:

    • Update frequency (including time of day and day of week)
    • Pull request limits (per update run and/or open at any time)
    • Out-of-range updates (receive only lockfile updates, if desired)
    • Security updates (receive only security updates, if desired)
    Reviewed by dependabot-preview[bot] at 2019-10-20 18:22
  • 8. Bump esri-leaflet from 2.3.0 to 2.3.1

    Bumps esri-leaflet from 2.3.0 to 2.3.1.

    Release notes

    Sourced from esri-leaflet's releases.

    v2.3.1

    Fixed

    • ?undefined issue when using DynamicMapLayer and Proxy (#1164)

    Changed

    • REST calls will now use outSR instead of outSr (#1168)
    Changelog

    Sourced from esri-leaflet's changelog.

    [2.3.1] - 2019-10-10

    Fixed

    • ?undefined issue when using DynamicMapLayer and Proxy (#1164)

    Changed

    • REST calls will now use outSR instead of outSr (#1168)
    Commits
    Maintainer changes

    This version was pushed to npm by gavinr, a new releaser for esri-leaflet since your current version.


    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Note: This repo was added to Dependabot recently, so you'll receive a maximum of 5 PRs for your first few update runs. Once an update run creates fewer than 5 PRs we'll remove that limit.

    You can always request more updates by clicking Bump now in your Dependabot dashboard.

    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
    • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

    Additionally, you can set the following in your Dependabot dashboard:

    • Update frequency (including time of day and day of week)
    • Pull request limits (per update run and/or open at any time)
    • Out-of-range updates (receive only lockfile updates, if desired)
    • Security updates (receive only security updates, if desired)
    Reviewed by dependabot-preview[bot] at 2019-10-20 18:21
  • 9. Bump @vue/cli-plugin-eslint from 3.11.0 to 4.0.4

    Bumps @vue/cli-plugin-eslint from 3.11.0 to 4.0.4.

    Release notes

    Sourced from @vue/cli-plugin-eslint's releases.

    v4.0.4

    We've also released v3.12.1 to address the router plugin issue in a different way. See the release notes for more explanation.

    :bug: Bug Fix

    • @vue/cli-service
      • #4711 fix: fix a typo that caused router failed to install in CLI 3.x (@​sodatea)

    :memo: Documentation

    Committers: 2

    v4.0.3

    :bug: Bug Fix

    • @vue/cli-ui, @vue/cli
    • @vue/cli-service
      • #4696 fix: allow v3 cli to invoke vuex & router plugin from inside cli-service v4 (@​sodatea)
    • @vue/cli-plugin-eslint, @vue/cli-plugin-typescript, @vue/cli-ui

    Committers: 1

    v4.0.2

    :bug: Bug Fix

    • @vue/cli-service
      • #4693 fix: add a compatibility layer for router & vuex for CLI v3 & CLI UI (@​sodatea)

    Committers: 1

    v4.0.1

    :bug: Bug Fix

    • @vue/cli-plugin-eslint, @vue/cli-plugin-router, @vue/cli-plugin-vuex

    v4.0.0

    We're happy to announce the release of Vue CLI version 4!

    This major version bump is focused on necessary version bumps of underlying tools, better default setups, and other fine-tunings required for long-term maintenance.

    We expect a smooth migration experience for most users.

    You can view the full migration guide at https://cli.vuejs.org/migrating-from-v3/


    ... (truncated)
    Changelog

    Sourced from @vue/cli-plugin-eslint's changelog.

    4.0.4 (2019-10-18)

    :bug: Bug Fix

    • @vue/cli-service
      • #4711 fix: fix a typo that caused router failed to install in older versions (@​sodatea)

    :memo: Documentation

    Committers: 2

    4.0.3 (2019-10-17)

    :bug: Bug Fix

    • @vue/cli-ui, @vue/cli
    • @vue/cli-service
      • #4696 fix: allow v3 cli to invoke vuex & router plugin from inside cli-service (@​sodatea)
    • @vue/cli-plugin-eslint, @vue/cli-plugin-typescript, @vue/cli-ui

    Committers: 1

    4.0.2 (2019-10-17)

    :bug: Bug Fix

    • @vue/cli-service
      • #4693 fix: add a compatibility layer for router & vuex for CLI v3 (@​sodatea)

    Committers: 1

    4.0.1 (2019-10-16)

    :bug: Bug Fix

    • @vue/cli-plugin-eslint, @vue/cli-plugin-router, @vue/cli-plugin-vuex, @vue/cli-service-global, @vue/cli-ui-addon-webpack, @vue/cli-ui-addon-widgets, @vue/cli-ui, @vue/cli

    4.0.0 (2019-10-16)

    ... (truncated)
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Note: This repo was added to Dependabot recently, so you'll receive a maximum of 5 PRs for your first few update runs. Once an update run creates fewer than 5 PRs we'll remove that limit.

    You can always request more updates by clicking Bump now in your Dependabot dashboard.

    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
    • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

    Additionally, you can set the following in your Dependabot dashboard:

    • Update frequency (including time of day and day of week)
    • Pull request limits (per update run and/or open at any time)
    • Out-of-range updates (receive only lockfile updates, if desired)
    • Security updates (receive only security updates, if desired)
    Reviewed by dependabot-preview[bot] at 2019-10-20 18:20
Vue 2 components for Leaflet maps
Vue 2 components for Leaflet maps

Vue2Leaflet Vue2Leaflet is a JavaScript library for the Vue framework that wraps Leaflet making it easy to create reactive maps. How to install npm in

May 24, 2022
Baidu Map components for Vue 2.x
Baidu Map components for Vue 2.x

VUE BAIDU MAP Baidu Map components for Vue 2.x Languages 中文 English Documentation https://dafrok.github.io/vue-baidu-map Get Start Installation npm i

May 24, 2022
Web map Vue components with the power of OpenLayers

VueLayers Web map Vue components with the power of OpenLayers Overview VueLayers is components library that brings the powerful OpenLayers API to the

May 19, 2022
Vue 2.x components for CesiumJS.
Vue 2.x components for CesiumJS.

VUE CESIUM Vue 2.x components for CesiumJS. Load Cesium built package or other third-party packages which are built on Cesium. Languages 中文 English Li

May 23, 2022
A set of composable components for easy use of Google Maps in your Vue 3 projects.

A set of composable components for easy use of Google Maps in your Vue 3 projects.

May 26, 2022
Web map Vue 3.x components with the power of OpenLayers
Web map Vue 3.x components with the power of OpenLayers

vue3-openlayers Web map Vue components with the power of OpenLayers Overview vue3-openlayers is components library that brings the powerful OpenLayers

May 26, 2022
Reactive Vue 3 components for Google maps

Vue 3 Google maps Components Set of mostly used Google Maps components for Vue.js. Why this library exists? We heavily use Google Maps in our projects

May 23, 2022
A set of Vue.js components to display an interactive SVG map

vue-svg-map A set of Vue.js components to display an interactive SVG map. Demo Take a look at the live demo! Installation npm npm install --save vue-s

May 26, 2022
Vuejs 2 components for interacting with mapbox-gl-js

VueMapbox Combine powers of Vue.js and Mapbox Gl JS Vue-mapbox is wrapper around Mapbox GL JS library that provides vueish-way to interact with the ma

May 16, 2022
Отрисовка карты офиса и круговой диаграммы Vue.js с использованием библиотек D3.js, vue-chartjs, vuedraggable
Отрисовка карты офиса и круговой диаграммы Vue.js с использованием библиотек D3.js, vue-chartjs, vuedraggable

office-map Отрисовка карты офиса и круговой диаграммы Vue.js с использованием библиотек D3.js, vue-chartjs, vuedraggable загрузка из JSON информации о

May 9, 2022
Google maps component for vue with 2-way data binding

CONTRIBUTORS NEEDED! It's been increasingly difficult for me to make time to maintain this project. My projects at work have also gradually migrated a

May 24, 2022
A Vue.js component for Mapbox GL JS

Mapbox GL JS Vue.js A simple lightweight (9kb/3kb gzipped) Mapbox GL JS Vue component. Demo Installation Setup Props Events Plugins Popups Development

Mar 21, 2022
Choropleth Map component for Vue.js

vue-choropleth Vue components to display a choropleth map given a certain GeoJSON and another datasource to show information from. Using Vue2Leaflet H

Feb 12, 2022
Integrate Google Maps in your Vue application
Integrate Google Maps in your Vue application

vue-googlemaps Integrate Google Maps in your Vue application in a "Vue-way". This library is Work In Progress. More components will be available in th

Apr 10, 2022
A cloned & maintained version of vue-mapbox

V-Mapbox ?? Combine powers of Vue.js and Mapbox GL JS NOTE: This is a maintained version of vue-mapbox V-Mapbox is wrapper around Mapbox GL JS library

May 15, 2022
A lightweight Google Maps plugin for Vue
A lightweight Google Maps plugin for Vue

x5-gmaps (Live Demo) This is a lightweight Google Maps plugin for Vue. Samples/examples/tutorials Tutorial creating a COVID Heatmap Address Autocomple

Apr 22, 2022
vue google map custom marker component
vue google map custom marker component

vue2-gmap-custom-marker This component allows you to display custom HTML content on the map using Overlay. This component is an adaptation of the Goog

May 17, 2022
Google maps component for vue with 2-way data binding

vue-google-maps Demo: Demo in production Showcase with a lot of features Presentation If you want to write google map this way : <map :center="{lat:

May 10, 2022
Wrapper for vue-mapbox-geocoder

v-mapbox-geocoder ?? v-mapbox plugin for mapbox-gl-geocoder support. Setup First of all you need to install mapbox-gl-geocoder and v-mapbox. See v-map

Sep 18, 2021