🌟Shards Vue is a free, beautiful and modern Vue.js UI kit based on Shards.

Overview

Shards Vue is a free, beautiful and modern Vue.js UI kit
based on Shards.



Documentation & DemoOfficial Page

Getting Started

Getting started with Shards Vue is fairly simple. You can download Shards Vue via the official website, here on GitHub as a release package or by using a package manager such as Yarn or NPM.


Quick Start

You can install Shards Vue via Yarn or NPM.

// Install via Yarn
yarn add shards-vue

// Install via NPM
npm i shards-vue

Module Bundlers

If you are using a module bundler such as Webpack or Rollup, you can include the entire Shards Vue library inside your project.

import Vue from 'vue'
import ShardsVue from 'shards-vue'

// Import base styles (Bootstrap and Shards)
import 'bootstrap/dist/css/bootstrap.css'
import 'shards-ui/dist/css/shards.css'

Vue.use(ShardsVue);

Registering Components as Vue Plugins

If you'd like to register only certain components as Vue plugins, make sure to import just the component you'd like to use.

import Vue from 'vue'

// Import base styles (Bootstrap and Shards)
import 'bootstrap/dist/css/bootstrap.css'
import 'shards-ui/dist/css/shards.css'

import { Button } from 'shards-vue/src/components'
Vue.use(Button)

Importing Single File Components

Importing single file components is also possible.

<template>
    <d-button @click="handleClick">Click Me!</d-button>
</template>

<script>
import dButton from 'shards-vue/src/components/button/Button'

export default {
    components: {
        dButton
    },
    methods: {
        handleClick() {
            alert('You just clicked me!')
        }
    }
}
</script>

File Sizes

You can also run yarn bundlesize at any time to check the compiled file sizes.

File Name Size (min.gz)
shards-vue.common.min.js 46.29KB
shards-vue.esm.min.js 46.24KB
shards-vue.umd.min.js 39.3KB

Built Using


Contributing

Please read CONTRIBUTING.md for details on our code of conduct, and the process for submitting pull requests to us.

If you'd like to fix a bug or work on a feature, make sure to follow the steps below in order to setup the development environment on your local machine:

  1. Clone the repository.
  2. Run yarn to install all required dependencies.
  3. Install Vue CLI and the CLI service globally by running: npm i -g @vue/cli @vue/cli-service-global or yarn global add @vue/cli-service-global.
  4. Run yarn watch in order to kickstart the server and run the sandbox with hot reloading.
  5. Refer to the sandbox/Sandbox.vue file for more details.

Roadmap

View the roadmap.


Changelog

View notable changes.

Comments
  •  Cannot read property 'version' of undefined

    Cannot read property 'version' of undefined

    Expected Behavior

    $ vue serve sandbox/Sandbox.vue
    (node:10408) UnhandledPromiseRejectionWarning: TypeError: Cannot read property 'version' of undefined
        at module.exports (C:\Users\DELL\AppData\Roaming\npm\node_modules\@vue\cli-service-global\node_modules\@vue\cli-plugin-eslint\index.js:18:29)
        at plugins.forEach (C:\Users\DELL\AppData\Roaming\npm\node_modules\@vue\cli-service-global\node_modules\@vue\cli-service\lib\Service.js:79:7)
        at Array.forEach (<anonymous>)
        at Service.init (C:\Users\DELL\AppData\Roaming\npm\node_modules\@vue\cli-service-global\node_modules\@vue\cli-service\lib\Service.js:78:18)
        at Service.run (C:\Users\DELL\AppData\Roaming\npm\node_modules\@vue\cli-service-global\node_modules\@vue\cli-service\lib\Service.js:204:10)
        at Object.exports.serve (C:\Users\DELL\AppData\Roaming\npm\node_modules\@vue\cli-service-global\index.js:54:33)
        at Command.program.command.description.option.option.action (C:\Users\DELL\AppData\Roaming\npm\node_modules\@vue\cli\bin\vue.js:102:53)
        at Command.listener (C:\Users\DELL\AppData\Roaming\npm\node_modules\@vue\cli\node_modules\commander\index.js:315:8)
        at emitTwo (events.js:126:13)
        at Command.emit (events.js:214:7)
    (node:10408) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
    (node:10408) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code. Done in 0.57s.
    

    Current Behavior

     npm i @vue/[email protected] -g
    
    opened by Sinosaurus 3
  • Exact prop does not work on d-nav-item

    Exact prop does not work on d-nav-item

    Expected Behavior

    The d-nav-item with an :exact prop should not have an active class when it is not the current active route

    Current Behavior

    Even after applying the active prop to a d-nav-item, an active class is always applied to it as long as the current path is preceeded by the path of the d-nav-item with the exact prop.

    <d-collapse is-nav id="nav-collapse" class="justify-content-md-center">
        <d-navbar-nav>
            <d-nav-item to="/" exact>Home</d-nav-item>
            <d-nav-item to="/portfolio">Portfolio</d-nav-item>
            <d-nav-item to="/stocks">Stocks</d-nav-item>
            <d-nav-item to="">End Day</d-nav-item>
            <d-dropdown text="Save & Load" is-nav>
                <d-dropdown-item>Action</d-dropdown-item>
                <d-dropdown-item>Another action</d-dropdown-item>
                <d-dropdown-item>Something else here</d-dropdown-item>
                <d-dropdown-divider />
                <d-dropdown-item>Separated link</d-dropdown-item>
            </d-dropdown>
        </d-navbar-nav>
    </d-collapse>
    
    export default new Router({
        linkActiveClass: 'active',
        linkExactActiveClass: 'exact-active',
       // more router options
    })
    
    

    Result

    untitled

    bug 
    opened by simioluwatomi 3
  • d-textarea does not have property max-rows

    d-textarea does not have property max-rows

    First of all, thanks for your UI

    Expected Behavior

    In documentation said, that d-textarea has property :max-rows for auto change textarea height. https://designrevision.com/docs/shards-vue/components/form-textarea

    Current Behavior

    In code of d-textarea component nothing about this prop :( Of course, it`s not working https://github.com/DesignRevision/shards-vue/blob/master/src/components/form-textarea/FormTextarea.vue

    bug 
    opened by reznikartem 2
  • Slider converts Number values into String

    Slider converts Number values into String

    Expected Behavior

    When you use a <d-slider :v-model="test"> component to alter a data() variable test, test takes on the value of the slider of type Number.

    Current Behavior

    Even if variable test is a Number before, after slider updates will convert it into a String.

    Steps to Reproduce

    Just bind d-slider to any variable, bug is very consistent.

    Context (Environment)

    I am using d-slider components to test if my system is updating correctly (during development). Currently I have to parseFloat all my variables that I want to change, which is fairly tedious.

    Possible Solution / Possible Implementation

    Use parseFloat on the value that is emitted perhaps?

    opened by iamDecode 2
  • d-nav-item and d-link won't work with named routes

    d-nav-item and d-link won't work with named routes

    first of all, thank you very much for this awesome ui kit!

    Expected Behavior

    the :to prop for d-nav-item and d-link should work like the same way router-link :to does. how they should work

    Current Behavior

    d-nav-item and d-link :to prop only accepts a string or an object with a path prop

    Steps to Reproduce

    1. use a d-nav-item or d-link with a named route
    2. will produce href="#"

    Context (Environment)

    i mainly use named routes in my apps so this would be awesome if it would work

    opened by St3Ko 2
  • chore(deps-dev): bump node-sass from 4.9.3 to 4.13.1

    chore(deps-dev): bump node-sass from 4.9.3 to 4.13.1

    Bumps node-sass from 4.9.3 to 4.13.1.

    Release notes

    Sourced from node-sass's releases.

    v4.13.1

    Community

    Supported Environments

    OS Architecture Node
    Windows x86 & x64 0.10, 0.12, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
    OSX x64 0.10, 0.12, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
    Linux* x86 & x64 0.10, 0.12, 1, 2, 3, 4, 5, 6, 7, 8**, 9**, 10**^, 11**^, 12**^, 13**^
    Alpine Linux x64 6, 8, 10, 11, 12, 13
    FreeBSD i386 amd64 8, 10, 12, 13

    *Linux support refers to Ubuntu, Debian, and CentOS 5+ ** Not available on CentOS 5 ^ Only available on x64

    v4.13.0

    Features

    Community

    Dependencies

    Supported Environments

    OS Architecture Node
    Windows x86 & x64 0.10, 0.12, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
    OSX x64 0.10, 0.12, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
    Linux* x86 & x64 0.10, 0.12, 1, 2, 3, 4, 5, 6, 7, 8**, 9**, 10**^, 11**^, 12**^, 13**^
    Alpine Linux x64 6, 8, 10, 11, 12, 13
    FreeBSD i386 amd64 6, 8, 10, 12, 13

    *Linux support refers to Ubuntu, Debian, and CentOS 5+

    Changelog

    Sourced from node-sass's changelog.

    v4.13.1

    https://github.com/sass/node-sass/releases/tag/v4.13.1

    v4.13.0

    https://github.com/sass/node-sass/releases/tag/v4.13.0

    v4.12.0

    https://github.com/sass/node-sass/releases/tag/v4.12.0

    v4.11.0

    https://github.com/sass/node-sass/releases/tag/v4.11.0

    v4.10.0

    https://github.com/sass/node-sass/releases/tag/v4.10.0

    v4.9.4

    https://github.com/sass/node-sass/releases/tag/v4.9.4

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 1
  • chore(deps): bump lodash from 4.17.10 to 4.17.19

    chore(deps): bump lodash from 4.17.10 to 4.17.19

    Bumps lodash from 4.17.10 to 4.17.19.

    Release notes

    Sourced from lodash's releases.

    4.17.16

    Commits
    Maintainer changes

    This version was pushed to npm by mathias, a new releaser for lodash since your current version.


    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 1
  • Shards-vue don't trigger event modifiers - keydown

    Shards-vue don't trigger event modifiers - keydown

    Expected Behavior

    Inputs don't trigger event modifiers

    Current Behavior

    Usual input triggers event modifiers but d-input doesn't

    <d-input
       v-model="myData"
       v-on:keydown="keydownMethod"
    />
    

    Steps to Reproduce

    1. Create new vue-cli project
    2. Install and load ShardsVue
    3. Add <d-input ... v-on:keydown="keydownMethod" />
    4. Method is never triggered
    opened by c-zab 1
  • Icons component missing

    Icons component missing

    Expected Behavior

    According to the documentation, the only place where an icon is used is in the navigation and it was used this way:

    <fa :icon="['fas', 'search']" />
    

    however, when I do I get an error that the component fa is not registered

    Current Behavior

    There is no documentation on how to use icons nor an icon component.

    Note: I have tried to use the <i/> tag but it didn't work either.

    Steps to Reproduce

    described in first section

    Possible Solution

    Implement the fa component ?

    opened by gimyboya 1
  • Alert close button align issues

    Alert close button align issues

    Expected Behavior

    To be aligned as expected

    Current Behavior

    Align issues

    Steps to Reproduce

    1. Access https://designrevision.com/docs/shards-vue/components/alert
    2. At the dismissables
    3. Check the close button

    Context (Environment)

    Possible Solution

    // fix
    .alert-dismissible .close {
        top: 0;
        right: 0;
        padding: .75rem 1.25rem 1.25rem;
        transition: all .25s cubic-bezier(.27,.01,.38,1.06);
        line-height: 1.2rem;
    }
    
    // Previous
    .alert-dismissible .close {
        top: 0;
        right: 0;
        padding: .75rem 1.25rem;
        transition: all .25s cubic-bezier(.27,.01,.38,1.06);
    }
    
    bug 
    opened by rodrigorhas 1
  • Patch 1.0.4

    Patch 1.0.4

    • chore: update BS 4.1.3, Shards 2.1.0
    • chore: update dist
    • chore: update readme
    • fix: computed d-col offset and order classes
    • fix: incorrect use of .includes() in <d-list-group-item>
    • fix: propagate link-specific props for d-dropdown-item
    • feature(d-progress): add size prop + docs
    • fix(d-card): bind listeners to the card component
    • fix(d-datepicker): fix highlighted colors
    • feature(d-datepicker): impr. highlighted dates, add small datepicker prop/modifier
    • fix(d-datepicker): fix datepickers inside input groups
    • fix(d-input): allow file inputs (temp)
    • chore: bump version number (1.0.4), update dist + changelog
    opened by hisk 0
  • chore(deps): bump qs from 6.5.2 to 6.5.3

    chore(deps): bump qs from 6.5.2 to 6.5.3

    Bumps qs from 6.5.2 to 6.5.3.

    Changelog

    Sourced from qs's changelog.

    6.5.3

    • [Fix] parse: ignore __proto__ keys (#428)
    • [Fix] utils.merge: avoid a crash with a null target and a truthy non-array source
    • [Fix] correctly parse nested arrays
    • [Fix] stringify: fix a crash with strictNullHandling and a custom filter/serializeDate (#279)
    • [Fix] utils: merge: fix crash when source is a truthy primitive & no options are provided
    • [Fix] when parseArrays is false, properly handle keys ending in []
    • [Fix] fix for an impossible situation: when the formatter is called with a non-string value
    • [Fix] utils.merge: avoid a crash with a null target and an array source
    • [Refactor] utils: reduce observable [[Get]]s
    • [Refactor] use cached Array.isArray
    • [Refactor] stringify: Avoid arr = arr.concat(...), push to the existing instance (#269)
    • [Refactor] parse: only need to reassign the var once
    • [Robustness] stringify: avoid relying on a global undefined (#427)
    • [readme] remove travis badge; add github actions/codecov badges; update URLs
    • [Docs] Clean up license text so it’s properly detected as BSD-3-Clause
    • [Docs] Clarify the need for "arrayLimit" option
    • [meta] fix README.md (#399)
    • [meta] add FUNDING.yml
    • [actions] backport actions from main
    • [Tests] always use String(x) over x.toString()
    • [Tests] remove nonexistent tape option
    • [Dev Deps] backport from main
    Commits
    • 298bfa5 v6.5.3
    • ed0f5dc [Fix] parse: ignore __proto__ keys (#428)
    • 691e739 [Robustness] stringify: avoid relying on a global undefined (#427)
    • 1072d57 [readme] remove travis badge; add github actions/codecov badges; update URLs
    • 12ac1c4 [meta] fix README.md (#399)
    • 0338716 [actions] backport actions from main
    • 5639c20 Clean up license text so it’s properly detected as BSD-3-Clause
    • 51b8a0b add FUNDING.yml
    • 45f6759 [Fix] fix for an impossible situation: when the formatter is called with a no...
    • f814a7f [Dev Deps] backport from main
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • chore(deps): bump chownr from 1.0.1 to 1.1.4

    chore(deps): bump chownr from 1.0.1 to 1.1.4

    Bumps chownr from 1.0.1 to 1.1.4.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • chore(deps-dev): bump node-sass from 4.9.3 to 7.0.0

    chore(deps-dev): bump node-sass from 4.9.3 to 7.0.0

    Bumps node-sass from 4.9.3 to 7.0.0.

    Release notes

    Sourced from node-sass's releases.

    v7.0.0

    Breaking changes

    Features

    Dependencies

    Community

    • Remove double word "support" from documentation (@​pzrq, #3159)

    Misc

    Supported Environments

    OS Architecture Node
    Windows x86 & x64 12, 14, 16, 17
    OSX x64 12, 14, 16, 17
    Linux* x64 12, 14, 16, 17
    Alpine Linux x64 12, 14, 16, 17
    FreeBSD i386 amd64 12, 14

    *Linux support refers to major distributions like Ubuntu, and Debian

    v6.0.1

    Dependencies

    Misc

    Supported Environments

    ... (truncated)

    Changelog

    Sourced from node-sass's changelog.

    v4.14.0

    https://github.com/sass/node-sass/releases/tag/v4.14.0

    v4.13.1

    https://github.com/sass/node-sass/releases/tag/v4.13.1

    v4.13.0

    https://github.com/sass/node-sass/releases/tag/v4.13.0

    v4.12.0

    https://github.com/sass/node-sass/releases/tag/v4.12.0

    v4.11.0

    https://github.com/sass/node-sass/releases/tag/v4.11.0

    v4.10.0

    https://github.com/sass/node-sass/releases/tag/v4.10.0

    v4.9.4

    https://github.com/sass/node-sass/releases/tag/v4.9.4

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • chore(deps): bump path-parse from 1.0.5 to 1.0.7

    chore(deps): bump path-parse from 1.0.5 to 1.0.7

    Bumps path-parse from 1.0.5 to 1.0.7.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • chore(deps): bump tar from 2.2.1 to 2.2.2

    chore(deps): bump tar from 2.2.1 to 2.2.2

    Bumps tar from 2.2.1 to 2.2.2.

    Commits
    • 523c5c7 2.2.2
    • 7ecef07 Bump fstream to fix hardlink overwriting vulnerability
    • 9fc84b9 Use {} for hardlink tracking instead of []
    • 15e59f1 Only track previously seen hardlinks
    • 4f85851 Ignore potentially unsafe files
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
Releases(v1.0.6)
  • v1.0.6(Dec 20, 2018)

    • compat: fix IE11 conflict
    • fix(d-form-checkbox): remove unnecessary :checked binding.
    • fix(d-form-radio): remove unnecessary :checked binding.
    Source code(tar.gz)
    Source code(zip)
  • v1.0.4(Oct 15, 2018)

    • feature(d-datepicker): impr. highlighted dates, add small datepicker prop/modifier
    • feature(d-progress): add size prop + docs
    • fix(d-input): allow file inputs (temp)
    • fix(d-datepicker): fix datepickers inside input groups
    • fix(d-datepicker): fix highlighted colors
    • fix(d-card): bind listeners to the card component
    • fix: propagate link-specific props for d-dropdown-item
    • fix: incorrect use of .includes() in <d-list-group-item>
    • fix: computed d-col offset and order classes
    • chore: update readme
    Source code(tar.gz)
    Source code(zip)
    shards-vue.1.0.4.zip(944.23 KB)
Owner
DesignRevision
We help designers and developers finish their projects in time and ship faster.
DesignRevision
Vue Bootstrap with Material Design - Powerful and free UI KIT

Vue Bootstrap with Material Design Based on the latest Bootstrap 4 and Vue. 400+ material UI elemens, 600+ material icons, 74 CSS animations, SASS fil

MDBootstrap 902 Jan 4, 2023
A fresh and flat UI-Kit specially for desktop application with Vue.js 2.0

AT-UI Style AT-UI Style is an ui component library based on Flexbox, be used for AT-UI Install npm install at-ui-style Usage import 'at-ui-style' Cont

null 96 Jan 4, 2023
Vue 3 & Bootstrap 5 & Material Design 2.0 UI KIT

Vue 3 & Bootstrap 5 & Material Design 2.0 UI KIT

MDBootstrap 899 Dec 29, 2022
Modern UI Library that is beautifully designed and ready to use.

Jenika-UI Modern UI Library that is beautifully designed and build projects on top of that. Installation Install from your favourite package managers.

Anbuselvan Rocky 3 Sep 16, 2022
Free and Open Source UI Library for Vue 3 🤘

Free and Open Source UI Library for Vue 3 ??

Epicmax 2k Jan 7, 2023
Customization-first, performance-oriented and elegant UI framework for eCommerce (and not only) based on Vue.js and Google Retail UX Playbook.

Storefront UI Current status: Stable beta! Customization-first, performance-oriented and elegant UI framework for eCommerce (and not only) based on Vu

Vue Storefront 2k Dec 30, 2022
:diamonds: A modular and customizable UI library based on Material Design and Vue

BalmUI Next Generation Material UI for Vue.js Introduction BalmUI is a modular and customizable Material Design UI library for Vue.js. ?? NOW, balm-ui

BalmJS 428 Jan 4, 2023
🌈 An enterprise-class UI components based on Ant Design and Vue. 🐜

Ant Design Vue An enterprise-class UI components based on Ant Design and Vue. English | 简体中文 Features An enterprise-class UI design system for desktop

vueComponent 17.6k Jan 4, 2023
Fast, Responsive, Multi Language, Both Direction Support and Configurable UI Framework based on Vue.js.

Framevuerk Fast, Responsive, Without Dependencies, Both Direction Support and Configurable UI Framework based on Vue.js. Setup First of all, you shoul

null 267 Nov 14, 2022
🧬Equal UI is a Vue 3 components library with 30+ components based on TypeScript and personal design system.

??Equal UI is a Vue 3 components library with 30+ components based on TypeScript and personal design system.

Yan Savinov 873 Jan 3, 2023
An enterprise-level UI component library and front-end solution based on Vue.js 3

An enterprise-level UI component library and front-end solution based on Vue.js 3

View Design 187 Dec 31, 2022
Lightweight UI components for Vue.js based on Bulma

Buefy is a lightweight library of responsive UI components for Vue.js based on Bulma framework and design. Features Keep your current Bulma theme / va

Buefy 9.4k Dec 30, 2022
Flow-UI is a highly customizable UI framework based Seajs/jQuery。

English | 中文 Flow-UI ?? Flow-UI is a highly customizable UI framework based Seajs/jQuery。 Introduction Flow-UI has built-in CSS components, JS plug-in

Flow-UI 84 Jul 26, 2022
BootstrapVue provides one of the most comprehensive implementations of Bootstrap v4 for Vue.js. With extensive and automated WAI-ARIA accessibility markup.

With more than 85 components, over 45 available plugins, several directives, and 1000+ icons, BootstrapVue provides one of the most comprehensive impl

BootstrapVue 14.2k Dec 31, 2022
⚡️ Build scalable and accessible Vue.js applications with ease.

Build scalable and accessible Vue.js applications with ease. @chakra-ui/vue gives you a set of accessible and composable Vue components that you can u

Chakra UI 1.7k Jan 6, 2023
ICIJ's Design System for Bootstrap 4 and Vue.js

Murmur is ICIJ's Design System for Bootstrap 4 and Vue.js Status CI checks Code Climate NPM version NPM downloads Installation guide If you are using

The International Consortium of Investigative Journalists 15 Nov 15, 2022
A library of UI widgets built using Vue.js and TailwindCSS.

This library contains a set of UI widgets / components. They range from something as simple as a button, to as complex as a fully-featured Markdown-based text editor. Originally, these components were exclusively part of Lumeno's codebase, however they have since been extracted, extended and made available for open-source use.

Lumeno 73 Dec 21, 2022
A library of UI components built using Vue.js and TailwindCSS

Varnish This library contains a set of UI components. They range from something as simple as a button, to as complex as a fully-featured, Markdown-bas

Caneara 73 Dec 21, 2022