Best-shot - a webpack config tool chain

Last update: Apr 9, 2022
Comments
  • 1. chore(deps): bump terser from 5.14.1 to 5.14.2

    Bumps terser from 5.14.1 to 5.14.2.

    Changelog

    Sourced from terser's changelog.

    v5.14.2

    • Security fix for RegExps that should not be evaluated (regexp DDOS)
    • Source maps improvements (#1211)
    • Performance improvements in long property access evaluation (#1213)
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2022-07-21 07:22
  • 2. chore(deps): bump async from 2.6.3 to 2.6.4

    Bumps async from 2.6.3 to 2.6.4.

    Changelog

    Sourced from async's changelog.

    v2.6.4

    • Fix potential prototype pollution exploit (#1828)
    Commits
    Maintainer changes

    This version was pushed to npm by hargasinski, a new releaser for async since your current version.


    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2022-05-17 09:00
  • 3. chore(deps): bump ejs from 3.1.6 to 3.1.7

    Bumps ejs from 3.1.6 to 3.1.7.

    Release notes

    Sourced from ejs's releases.

    v3.1.7

    Version 3.1.7

    Commits
    • 820855a Version 3.1.7
    • 076dcb6 Don't use template literal
    • faf8b84 Skip test -- error message vary depending on JS runtime
    • c028c34 Update packages
    • e4180b4 Merge pull request #629 from markbrouwer96/main
    • d5404d6 Updated jsdoc to 3.6.7
    • 7b0845d Merge pull request #609 from mde/dependabot/npm_and_yarn/glob-parent-5.1.2
    • 32fb8ee Bump glob-parent from 5.1.1 to 5.1.2
    • f21a9e4 Merge pull request #603 from mde/mde-null-proto-where-possible
    • a50e46f Merge pull request #606 from akash-55/main
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2022-04-28 03:30
  • 4. chore(deps): bump minimist from 1.2.5 to 1.2.6

    Bumps minimist from 1.2.5 to 1.2.6.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2022-03-24 01:56
  • 5. chore(deps): bump node-forge from 1.2.1 to 1.3.0

    Bumps node-forge from 1.2.1 to 1.3.0.

    Changelog

    Sourced from node-forge's changelog.

    1.3.0 - 2022-03-17

    Security

    • Three RSA PKCS#1 v1.5 signature verification issues were reported by Moosa Yahyazadeh ([email protected]).
    • HIGH: Leniency in checking digestAlgorithm structure can lead to signature forgery.
    • HIGH: Failing to check tailing garbage bytes can lead to signature forgery.
    • MEDIUM: Leniency in checking type octet.
      • DigestInfo is not properly checked for proper ASN.1 structure. This can lead to successful verification with signatures that contain invalid structures but a valid digest.
      • CVE ID: CVE-2022-24773
      • GHSA ID: GHSA-2r2c-g63r-vccr

    Fixed

    • [asn1] Add fallback to pretty print invalid UTF8 data.
    • [asn1] fromDer is now more strict and will default to ensuring all input bytes are parsed or throw an error. A new option parseAllBytes can disable this behavior.
      • NOTE: The previous behavior is being changed since it can lead to security issues with crafted inputs. It is possible that code doing custom DER parsing may need to adapt to this new behavior and optional flag.
    • [rsa] Add and use a validator to check for proper structure of parsed ASN.1 RSASSA-PKCS-v1_5 DigestInfo data. Additionally check that the hash algorithm identifier is a known value from RFC 8017 PKCS1-v1-5DigestAlgorithms. An invalid DigestInfo or algorithm identifier will now throw an error.
      • NOTE: The previous lenient behavior is being changed to be more strict since it could lead to security issues with crafted inputs. It is possible that code may have to handle the errors from these stricter checks.

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2022-03-22 18:22
  • 6. chore(deps): bump follow-redirects from 1.14.7 to 1.14.8

    Bumps follow-redirects from 1.14.7 to 1.14.8.

    Commits
    • 3d81dc3 Release version 1.14.8 of the npm package.
    • 62e546a Drop confidential headers across schemes.
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2022-02-12 06:51
  • 7. chore(deps): bump follow-redirects from 1.14.5 to 1.14.7

    Bumps follow-redirects from 1.14.5 to 1.14.7.

    Commits
    • 2ede36d Release version 1.14.7 of the npm package.
    • 8b347cb Drop Cookie header across domains.
    • 6f5029a Release version 1.14.6 of the npm package.
    • af706be Ignore null headers.
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2022-01-13 09:43
  • 8. chore(deps): bump ssri from 8.0.0 to 8.0.1

    Bumps ssri from 8.0.0 to 8.0.1.

    Changelog

    Sourced from ssri's changelog.

    8.0.1 (2021-01-27)

    Bug Fixes

    • simplify regex for strict mode, add tests (76e2233)
    Commits
    • 3eec7a3 chore(release): 8.0.1
    • 2083289 chore: update package-lock and dev dependencies
    • 76e2233 fix: simplify regex for strict mode, add tests
    • See full diff in compare view
    Maintainer changes

    This version was pushed to npm by nlf, a new releaser for ssri since your current version.


    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2021-03-20 06:00
  • 9. chore(deps): bump elliptic from 6.5.3 to 6.5.4

    Bumps elliptic from 6.5.3 to 6.5.4.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2021-03-09 01:03
  • 10. build(deps): bump webpack-subresource-integrity from 1.4.1 to 1.5.1

    Bumps webpack-subresource-integrity from 1.4.1 to 1.5.1.

    Release notes

    Sourced from webpack-subresource-integrity's releases.

    v1.5.1

    • Fix a security issue where dynamically loaded chunks were not protected from tampering. This issue was introduced in v1.5.0. (#131)

    v1.5.0

    • Compatibility with Webpack 5
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2020-10-20 00:57
  • 11. Bump websocket-extensions from 0.1.3 to 0.1.4

    Bumps websocket-extensions from 0.1.3 to 0.1.4.

    Changelog

    Sourced from websocket-extensions's changelog.

    0.1.4 / 2020-06-02

    • Remove a ReDoS vulnerability in the header parser (CVE-2020-7662, reported by Robert McLaughlin)
    • Change license from MIT to Apache 2.0
    Commits
    • 8efd0cd Bump version to 0.1.4
    • 3dad4ad Remove ReDoS vulnerability in the Sec-WebSocket-Extensions header parser
    • 4a76c75 Add Node versions 13 and 14 on Travis
    • 44a677a Formatting change: {...} should have spaces inside the braces
    • f6c50ab Let npm reformat package.json
    • 2d211f3 Change markdown formatting of docs.
    • 0b62083 Update Travis target versions.
    • 729a465 Switch license to Apache 2.0.
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    Reviewed by dependabot[bot] at 2020-08-02 16:34
  • 12. chore(deps): update dependency @babel/plugin-transform-react-constant-elements to ^7.18.12

    Mend Renovate

    This PR contains the following updates:

    | Package | Change | Age | Adoption | Passing | Confidence | |---|---|---|---|---|---| | @babel/plugin-transform-react-constant-elements (source) | ^7.18.9 -> ^7.18.12 | age | adoption | passing | confidence |


    Release Notes

    babel/babel

    v7.18.12

    Compare Source

    :bug: Bug Fix
    • babel-plugin-transform-react-constant-elements
    • babel-generator
    • babel-plugin-transform-typescript

    Configuration

    📅 Schedule: Branch creation - At any time (no schedule defined), Automerge - At any time (no schedule defined).

    🚦 Automerge: Enabled.

    Rebasing: Whenever PR is behind base branch, or you tick the rebase/retry checkbox.

    🔕 Ignore: Close this PR and you won't be reminded about this update again.


    • [ ] If you want to rebase/retry this PR, click this checkbox.

    This PR has been generated by Mend Renovate. View repository job log here.

    Reviewed by renovate[bot] at 2022-08-03 01:57
  • 13. Dependency Dashboard

    This issue lists Renovate updates and detected dependencies. Read the Dependency Dashboard docs to learn more.

    Awaiting Schedule

    These updates are awaiting their schedule. Click on a checkbox to get an update now.

    • [ ] chore(deps): lock file maintenance

    Pending Status Checks

    These updates await pending status checks. To force their creation now, click the checkbox below.

    • [ ] chore(deps): update dependency @bring-it/npm to ^0.0.3
    • [ ] chore(deps): update dependency @types/react to ^18.0.17
    • [ ] chore(deps): update dependency postcss to ^8.4.16
    • [ ] chore(deps): update nice-move packages (@nice-move/eslint-config-base, stylelint)
    • [ ] chore(deps): update dependency webpack-dev-server to ^4.10.0
    • [ ] fix(deps): update dependency @ltd/j-toml to ^1.32.0
    • [ ] fix(deps): update dependency launch-editor-middleware to ^2.5.0
    • [ ] fix(deps): update dependency sass to ^1.54.4

    Open

    These updates have all been created already. Click a checkbox below to force a retry/rebase of any.

    Detected dependencies

    github-actions
    .github/workflows/bring-it.yaml
    • airkro/bring-it actions
    • airkro/bring-it actions
    npm
    package.json
    • react ^18.2.0
    • react-dom ^18.2.0
    • vue ^3.2.37
    • @babel/core ^7.18.10
    • @bring-it/npm ^0.0.1
    • @nice-move/cli ^0.9.8
    • @nice-move/eslint-config-base ^0.8.3
    • @nice-move/prettier-config ^0.7.1
    • @nice-move/stylelint-config ^0.7.1
    • @types/react ^18.0.15
    • ava ^4.3.1
    • delay ^5.0.0
    • eslint ^8.21.0
    • eslint-plugin-ava ^13.2.0
    • garou ^0.5.0
    • prettier ^2.7.1
    • stylelint ^14.9.1
    • typescript ^4.7.4
    • webpack ^5.74.0
    • webpack-cli ^4.10.0
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/analyzer/package.json
    • @best-shot/config ^0.2.4
    • webpack-bundle-analyzer ^4.5.0
    • @best-shot/cli ^0.12.2
    • @best-shot/core ^0.6.0
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/best-shot/package.json
    • browserslist ^4.21.3
    • terser-webpack-plugin ^5.3.3
    • webpack ^5.74.0
    • yaml-loader ^0.8.0
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/cli/package.json
    • @best-shot/config ^0.2.12
    • chalk ^5.0.1
    • cheetor ^0.13.0
    • webpackbar ^5.0.2
    • @best-shot/core ^0.6.12
    • webpack ^5.72.1
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/config/package.json
    • @best-shot/validator ^0.2.2
    • @ltd/j-toml ^1.30.0
    • @nice-labs/git-rev ^3.5.0
    • chalk ^5.0.1
    • flat ^5.0.2
    • ini ^3.0.0
    • prompts ^2.4.2
    • yaml ^2.1.1
    • @best-shot/core ^0.6.14
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/core/package.json
    • @best-shot/validator ^0.2.2
    • browserslist ^4.21.3
    • case-sensitive-paths-webpack-plugin ^2.4.0
    • chalk ^5.0.1
    • copy-webpack ^2.0.4
    • deepmerge ^4.2.2
    • ext-to-regexp ^0.1.0
    • json-minimizer-webpack-plugin ^4.0.0
    • node-hmr-plugin ^1.0.1
    • slash ^4.0.0
    • slash-to-regexp ^0.0.4
    • terser-webpack-plugin ^5.3.3
    • webpack-chain ^6.5.1
    • yaml-loader ^0.8.0
    • webpack ^5.74.0
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/dev-server/package.json
    • @best-shot/config ^0.2.8
    • chalk ^5.0.1
    • ejs ^3.1.8
    • express ^4.18.1
    • launch-editor-middleware ^2.4.0
    • webpack-dev-server ^4.9.3
    • webpack-dev-server-waitpage ^2.1.1
    • @best-shot/cli ^0.12.4
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/inspector/package.json
    • @best-shot/config ^0.2.4
    • fs-extra ^10.1.0
    • javascript-stringify ^2.1.0
    • sort-keys ^5.0.0
    • @best-shot/cli ^0.12.2
    • @best-shot/core ^0.6.0
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/preset-asset/package.json
    • @sindresorhus/transliterate ^1.5.0
    • @squoosh/lib ^0.4.0
    • @wasm-codecs/gifsicle ^1.0.0
    • ext-to-regexp ^0.1.0
    • image-minimizer-webpack-plugin ^3.2.3
    • svgo ^2.8.0
    • svgo-config ^0.4.1
    • @best-shot/core ^0.6.14
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/preset-babel/package.json
    • @babel/preset-typescript ^7.18.6
    • babel-loader ^8.2.5
    • babel-preset-evergreen ^0.8.12
    • browserslist ^4.21.3
    • ext-to-regexp ^0.1.0
    • slash-to-regexp ^0.0.4
    • @babel/core ^7.18.10
    • @best-shot/core ^0.6.19
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/preset-react/package.json
    • @babel/plugin-transform-react-constant-elements ^7.18.9
    • @babel/plugin-transform-react-inline-elements ^7.18.6
    • @babel/preset-react ^7.18.6
    • @pmmmwh/react-refresh-webpack-plugin ^0.5.7
    • babel-plugin-transform-react-remove-prop-types ^0.4.24
    • react-refresh ^0.14.0
    • settingz ^0.2.0
    • @best-shot/core ^0.6.19
    • @best-shot/preset-babel ^0.12.3
    • react ^16.14.0 || ^17.0.2 || ^18.2.0
    • react-dom ^16.14.0 || ^17.0.2 || ^18.2.0
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/preset-style/package.json
    • css-loader ^6.7.1
    • css-minimizer-webpack-plugin ^4.0.0
    • cssnano ^5.1.12
    • ext-to-regexp ^0.1.0
    • less ^4.1.3
    • less-loader ^11.0.0
    • mini-css-extract-plugin ^2.6.1
    • postcss ^8.4.14
    • postcss-loader ^7.0.1
    • postcss-preset-evergreen ^0.4.5
    • resolve-url-loader ^5.0.0
    • sass ^1.53.0
    • sass-loader ^13.0.2
    • slash-to-regexp ^0.0.4
    • style-loader ^3.3.1
    • @best-shot/core ^0.6.15
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/preset-vue/package.json
    • @best-shot/vue-loader 17.0.0-esm-0
    • css-loader ^6.7.1
    • ext-to-regexp ^0.1.0
    • settingz ^0.2.0
    • vue-loader ^15.10.0
    • vue-template-compiler ^2.7.8
    • @best-shot/core ^0.6.18
    • @best-shot/preset-style ^0.9.4
    • vue ^2.6.14 || ^3.2.37
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/preset-web/package.json
    • ext-to-regexp ^0.1.0
    • html-add-asset-webpack-plugin ^0.1.2
    • html-minimizer-webpack-plugin ^4.0.0
    • html-webpack-plugin ^5.5.0
    • micro-tpl-loader ^0.1.0
    • slash ^4.0.0
    • slash-to-regexp ^0.0.4
    • suffix ^1.0.0
    • webpack-subresource-integrity ^5.1.0
    • @best-shot/core ^0.6.15
    • webpack ^5.72.1
    • node ^14.17.0 || ^16.13.0 || >=18.0.0
    packages/validator/package.json
    • ajv ^8.11.0
    • ajv-formats ^2.1.1
    • ajv-keywords ^5.1.0
    • node ^14.17.0 || ^16.13.0 || >=18.0.0

    • [ ] Check this box to trigger a request for Renovate to run again on this repository
    Reviewed by renovate[bot] at 2021-08-30 09:16
Reef chain block explorer

Reef chain block explorer

Jun 15, 2022
Generator-webpack-vue: a simple yeoman generator to build a Webpack dev environment

generator-webpack-vue This is a simple yeoman generator to build a Webpack dev environment. Install You need yeoman to make this generator work: npm i

Sep 17, 2017
A Vue 2.x component of easy-to-config page visibility api

vue-page-visibility-awesome A Vue 2.x component of easy-to-config page visibility api Introduction Demo Install $ npm i vue-page-visibility-awesome --

Jul 30, 2020
Best laptops, phones and earphones suggestions in different price ranges for india

best-products Build Setup # install dependencies $ npm install # serve with hot reload at localhost:3000 $ npm run dev # build for production and la

Nov 8, 2021
👔 💼 Build fast 🚀 and easy multiple beautiful resumes and create your best CV ever!
👔 💼 Build fast 🚀 and easy multiple beautiful resumes and create your best CV ever!

best-resume-ever ?? ?? Build fast ?? and easy multiple beautiful resumes and create your best CV ever! Made with Vue and LESS. Cool Creative Green Pur

Aug 8, 2022
The best typing test for programmers

CodeRush The best typing test for programmers View Live · Report Bug · Request a Feature · Donate Table of Contents About the Project Built With Getti

May 15, 2022
Webpack/Rollup/Vite plugin to add multiple root-node support to Vue 2 SFCs

vue-frag-plugin Webpack/Rollup/Vite plugin to use multiple root nodes in Vue 2 Single-file Components (SFCs). Powered by vue-frag. <template> <!--

Jul 2, 2022
GUI tool to explore Slash Commands of your bot, built on Vue 3 and TailwindCSS 🚀
GUI tool to explore Slash Commands of your bot, built on Vue 3 and TailwindCSS 🚀

Slash Commands GUI Graphical User Interface to explore Slash Commands of your bot, built on Vue 3 and TailwindCSS ?? Features Everything you can do wi

Aug 10, 2022
L'atelier, a project management tool
L'atelier, a project management tool

L'atelier, a project management tool

Jul 17, 2022
Pathfinding visualization tool for pathfinding algorithm

Pathfinding Visualizer Welcome to my pathfinding visualizer, this pathfinding visualizer was inspired by Clément Mihailescu pathfinding algorithm proj

Feb 2, 2022
⚡ A beautiful Lanyard visualizer tool to display your Discord status online! Works with Spotify and all RPCs!
⚡ A beautiful Lanyard visualizer tool to display your Discord status online! Works with Spotify and all RPCs!

A service to see your Discord status online easy and for free with the help of the Lanyard API! To use this service, you have to be in Lanyard's Discord server so that it could monitor you, you can find the invite link in Lanyard's GitHub repository.

Aug 7, 2022
Cheat Facebook Algorithms is a tool that tries to simulate arabic chars shape with different unicode to cheat Facebook Algorithms.

Cheat Facebook Algorithms is a tool that tries to simulate arabic chars shape with different unicode to cheat Facebook Algorithms.

Feb 2, 2022
Vue front-end and back-end tool.

jVue 1. Class-based TS Vue 工程的类型检查需求,一直是一个大问题。 For Vue projects, the requirement of type checking has been a big problem so far. 现在我们可以像这样使用 TypeScrip

Jan 19, 2022
Gamebrary - Open source tool to organize video game collections.
Gamebrary - Open source tool to organize video game collections.

Gamebrary Open source tool to organize video game collections. Gamebrary is an open source tool that helps organize video game collections. Written in

Jun 14, 2022
CSS Transform Playground. Online tool to visualize 2D & 3D CSS3 Transform functions.

css-transform › css-transform.moro.es CSS3 Transform Functions Playground. Demo UI built with Vue, Gulp and LESS. Deployment via Netlify Development —

Aug 1, 2022
Solidity-Sign-Verify - Solidity Sign off-chain & Verify on-chain

Solidity Sign off-chain & Verify on-chain This is a project which signs message

Jul 3, 2022
📸 Website Shot - Capture a website screenshot online
 📸 Website Shot - Capture a website screenshot online

?? Generate a full web-page screenshot, Website-shot provides rich interface to make any kind of web screenshots online for free with no limits

Aug 4, 2022
webpack loader, loads the .md file and returns the webpack loader that contains the content string in the file to achieve the function of making webpack load the .md file

webpack loader, loads the .md file and returns the webpack loader that contains the content string in the file to achieve the function of making webpack load the .md file

Dec 28, 2020
Bytebase is a web-based, zero-config, dependency-free database schema change and version control management tool for developers and DBAs
Bytebase is a web-based, zero-config, dependency-free database schema change and version control management tool for developers and DBAs

Web-based, zero-config, dependency-free database schema change and version control tool for teams.

Aug 8, 2022
Reef chain block explorer

Reef chain block explorer

Jun 15, 2022