Native mobile applications using Vue and NativeScript.

Overview

styled with prettier npm license CircleCI Codecov

Supporting NativeScript-Vue

NativeScript-Vue is an MIT-licensed open source project made possible by our sponsors:

and these awesome backers:

  • Tiago Alves
  • Kamen Bundev
  • Jan Weller
  • OpenLitterMap
  • Aparajita Fishman
  • Hajnalka Molnár Csikós
  • Jen Looper
  • Packy Tagliaferro
  • Alexander Vakrilov
  • Dave
  • Todd Anglin
  • Mohamed Hussain
  • Gleb Zhelezin
  • Robert M. Svendsen
  • Andy Drexler
  • ChiwalahSoftware
  • Nayir Chami
  • Teon Ooi
  • Thomas Kuhlmann
  • Abdullah Al Mashmoum
  • Stian Årsnes
  • Robertino Vasilescu
  • Marc Lewis
  • Tom Coonen

If you'd like to join them, please consider becoming a backer / sponsor on Patreon.

A huge thank you for all of the backers / sponsors!


NativeScript Vue

This project integrates Vue and NativeScript, allowing you to build cross-platform iOS and Android apps using Vue.

Contributing

If you feel like contributing to this project, that’s awesome! Start by reading this repo’s CONTRIBUTING.MD file for details on the required development setup, how to send pull requests, and how to run this repo’s sample app.

If you have any questions, or you would like to get involved with NativeScript Vue, join us in the #vue channel on the NativeScript community Slack.

License

NativeScript-Vue is licensed under the MIT license

Comments
  • error following tutorial

    error following tutorial

    I installed nativescript-vue and I get an error running both npm run watch:ios and npm run watch:android

    fullstack-mobile
    > npm run watch -- --env.android
    
    
    > [email protected] watch /Users/username/projects/chovy/fullstack/fullstack-mobile
    > webpack --watch --env.tnsAction run "--env.android"
    
    info: Copying NativeScript plugins to template dependencies...
    info: Preparing NativeScript application from template...
    npm WARN [email protected] No repository field.
    
    info: Bundling application for android...
    
    Webpack is watching the files…
    
    Executing post-build scripts
    info: Running NativeScript application...
    error: uncaughtException: 127 date=Sun Jun 10 2018 16:27:16 GMT-0700 (PDT), pid=71776, uid=501, gid=20, cwd=/Users/username/projects/chovy/fullstack/fullstack-mobile, execPath=/Users/username/.nvm/versions/node/v10.3.0/bin/node, version=v10.3.0, argv=[/Users/username/.nvm/versions/node/v10.3.0/bin/node, /Users/username/projects/chovy/fullstack/fullstack-mobile/node_modules/.bin/webpack, --watch, --env.tnsAction, run, --env.android], rss=200503296, heapTotal=170078208, heapUsed=116691416, external=1601018, loadavg=[2.681640625, 2.453125, 2.33056640625], uptime=621168, trace=[], stack=undefined
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! [email protected] watch: `webpack --watch --env.tnsAction run "--env.android"`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the [email protected] watch script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /Users/username/.npm/_logs/2018-06-10T23_27_16_698Z-debug.log
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! [email protected] watch:android: `npm run watch -- --env.android`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the [email protected] watch:android script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /Users/username/.npm/_logs/2018-06-10T23_27_16_741Z-debug.log
    
    

    I'm using node v10

    priority:low 
    opened by ralyodio 28
  • When using $navigateTo I get

    When using $navigateTo I get "getFrameById() is deprecated. Use Frame.getFrameById() instead.'"

    Version

    2.4.0

    Reproduction link

    https://play.nativescript.org/?template=play-js&id=xsfX&v=4

    Platform and OS info

    vue cli 4.1.1, Windows 10 64, TNS 6.2.2, Android 9

    Steps to reproduce

    I upgraded to 6.2.2 a couple of days ago and everything worked well until now.

    I only have this: showUsers() { this.$navigateTo(this.users); },

    And the button look like this:

    <GridLayout columns="130, *" rows="auto" class="menu-item" @tap="showUsers()">
    <Image col="0" src="~/assets/images/app/menu-icons/users.png" width="40" horizontalAlignment="left" />
    <Label col="1" verticalAlignment="center">User summary</Label>
    

    In other words, nothing extraordinary at all. This is very worrying for me, as my app is not working at the moment and a lot of people are dependent on updates. Very critical for me and I guess for everyone else.

    User page look like this:

    What is expected?

    It's expected that the page changes and button working.

    What is actually happening?

    Nothing happens. Absolutely nothing. The consol says: JS: 'getFrameById() is deprecated. Use Frame.getFrameById() instead.'


    I can't stress this enough. Please help me out here! PS I was not abled to reproduce this on the playground, thus pasting a "bogus" URL in that input field. I'm so sorry. I hope you can help me out in any case.

    priority:normal 
    opened by coffeeneed 25
  • NS 4.0 and VueRouter

    NS 4.0 and VueRouter

    This is a discussion thread for implementing VueRouter with nativescript 4.0.

    The discussion has been started at https://github.com/nativescript-vue/nativescript-vue/issues/211 but moved here for visibility.

    Prior discussion about the router can be found here: https://github.com/nativescript-vue/nativescript-vue/issues/119

    router next 
    opened by rigor789 25
  • Add support for Vue Single File Components

    Add support for Vue Single File Components

    Related to #3

    We should support .vue files, since they are the reason (at least for me) that make vue awesome!

    Decide if .vue files can be used with JIT compilation, or only with AOT

    enhancement help wanted 
    opened by rigor789 23
  • RadListView not working with 2.0.0-alpha.1

    RadListView not working with 2.0.0-alpha.1

    Version

    2.0.0-alpha.1

    Reproduction link

    https://github.com/odai-alali/radlistview-test

    Platform and OS info

    Android 7.0 / NativeScript 4.1 / Windows 10

    Steps to reproduce

    run the application

    What is expected?

    RadListView to be rendered

    What is actually happening?

    render is wrong screen

    priority:normal 
    opened by odai-alali 20
  • Android application events are not fired

    Android application events are not fired

    Version

    1.3.2-rc.3

    Reproduction link

    https://github.com/msaelices/nativescript-vue-android-event-issue

    Platform and OS info

    Android 7.0 / NativeScript 3.4.1 / Ubuntu Xenial

    Steps to reproduce

    1. vue init nativescript-vue/vue-cli-template myproject

    2. Select default options: no vue-router, no vuex

    3. Add this code to the src/main.js file:

    # after import HelloWorld from './components/HelloWorld';
    const application = require('tns-core-modules/application')
    
    application.android.on(application.AndroidApplication.activityStartedEvent, args => {
      console.log('activityStarted event called')
    })
    

    What is expected?

    See the activityStarted event called message.

    What is actually happening?

    The console.log sentence is not reached. Even if you change the console.log to a throw Error('Foo') the error is not raised so that function is never reached.


    The issue is only happening with the vue-cli-template, which uses webpack for building the bundle. There are no issues with the nativescript-vue-template.

    Android 
    opened by msaelices 17
  • question about how this deals with html ?

    question about how this deals with html ?

    I'm still considering diving deep into trying to use this instead of React Native since my website is fully built-out with vue components already.

    But one thing that isn't clear is how your custom renderer deals with html and css. I imagine there's a limit to how much translation you can do between html/css and what nativescript uses for visual elements. So a project who's vue components are heavily tied in to html that's been positioned and styled using bootstrap grids for example.. most or all of that would be lost right? And you'd end up being able to re-use most of the vue logic but would have to replace the layout part by something more native to nativescript?

    Am I understanding that correctly?

    question 
    opened by vesper8 17
  • when using Vue.extend() the template block doesn't work

    when using Vue.extend() the template block doesn't work

    So instead of

    export default {
       data
       methods
       ...
    }
    

    If I instead do

    export default Vue.extend({
       data
       methods
       ...
    })
    

    Then the template is not loaded and I get You are running a runtime-only build of Vue warning. (Which is supposed to happen if template is string, or el is id, and no render function exists)

    opened by championswimmer 15
  • confirm not fired in mounted or created method

    confirm not fired in mounted or created method

    Version

    1.3.1

    Reproduction link

    https://play.nativescript.org/?template=play-vue&id=izHUgC&v=3

    Platform and OS info

    playground and android version

    Steps to reproduce

    please comment the timeout in and the confirm dialog appears after one second

    created() {
        console.log('created');
         // setTimeout(() => {
          confirm({
            title: "Your title",
            message: "Your message",
            okButtonText: "Your OK button text",
            cancelButtonText: "Your Cancel text"
          }).then(result => {
            console.log(result);
          });
       // }, 1000);
      },
    
    

    What is expected?

    confirm dialog should appear on created method

    What is actually happening?

    nothing!


    why is it working only with the timeout delay.

    priority:normal 
    opened by bluelemonade 14
  • Bug related to the life cycle of an Android application

    Bug related to the life cycle of an Android application

    From @Fabiyo-90 on April 17, 2018 18:48

    I am on android, once I press the button "back" and that the application is found in pause "onPause ()", and then I click on the icon of the application to engage "surResume ()" then the application bug. Once stop "onStop ()", click on the icon while it normally starts. Bug related to the life cycle of an Android application.

    Copied from original issue: nativescript-vue/nativescript-vue.org#95

    bug Android check-on-v2 
    opened by rigor789 14
  • iOS tap issue

    iOS tap issue

    when tapping any element on the sample apps, the app crashes:

    *** Assertion failure in -[UIGestureGraphEdge initWithLabel:sourceNode:targetNode:directed:], /BuildRoot/Library/Caches/com.apple.xbs/Sources/UIKit_Sim/UIKit-3600.7.47/Source/GestureGraph/UIGestureGraphEdge.m:25
    Jun  2 14:11:03 LOOPERMAC com.apple.CoreSimulator.SimDevice.1658C660-8802-4075-8603-2A0148C48692.launchd_sim[14161] (UIKitApplication:org.nativescript.vuesample[0x30e8][14183][43417]): Service exited due to Segmentation fault: 11
    
    bug 
    opened by jlooper 14
  • build(deps-dev): bump @babel/core from 7.17.10 to 7.20.2

    build(deps-dev): bump @babel/core from 7.17.10 to 7.20.2

    Bumps @babel/core from 7.17.10 to 7.20.2.

    Release notes

    Sourced from @​babel/core's releases.

    v7.20.1 (2022-11-01)

    Thanks @​ptomato for your first pull request!

    :bug: Bug Fix

    • babel-plugin-proposal-async-generator-functions
    • babel-plugin-proposal-class-properties, babel-traverse
    • babel-helpers, babel-plugin-proposal-duplicate-named-capturing-groups-regex, babel-plugin-transform-named-capturing-groups-regex
    • babel-parser
    • babel-helpers, babel-plugin-proposal-duplicate-named-capturing-groups-regex
    • babel-plugin-transform-async-to-generator, babel-plugin-transform-parameters, babel-preset-env

    :house: Internal

    Committers: 5

    v7.20.0 (2022-10-27)

    Thanks @​oceandrama for your first PR!

    :rocket: New Feature

    • babel-compat-data, babel-helper-compilation-targets, babel-preset-env
    • babel-plugin-syntax-typescript
    • babel-generator, babel-parser, babel-plugin-syntax-explicit-resource-management, babel-plugin-transform-block-scoping, babel-plugin-transform-destructuring, babel-standalone, babel-traverse, babel-types
    • babel-generator, babel-parser, babel-plugin-syntax-import-reflection, babel-standalone, babel-types
    • babel-generator, babel-helper-skip-transparent-expression-wrappers, babel-parser, babel-plugin-transform-typescript, babel-traverse, babel-types

    :bug: Bug Fix

    • babel-generator, babel-parser
    • babel-generator

    ... (truncated)

    Changelog

    Sourced from @​babel/core's changelog.

    v7.20.2 (2022-11-04)

    :bug: Bug Fix

    • babel-core, babel-helper-create-class-features-plugin, babel-helper-module-transforms, babel-helper-plugin-utils, babel-helper-simple-access, babel-node, babel-plugin-transform-block-scoping, babel-plugin-transform-classes, babel-plugin-transform-react-constant-elements, babel-preset-env, babel-standalone, babel-types
    • babel-plugin-transform-typescript
    • babel-parser
    • babel-generator
    • babel-plugin-proposal-decorators, babel-plugin-proposal-object-rest-spread, babel-plugin-transform-jscript
    • babel-plugin-transform-destructuring

    v7.20.1 (2022-11-01)

    :bug: Bug Fix

    • babel-plugin-proposal-async-generator-functions
    • babel-plugin-proposal-class-properties, babel-traverse
    • babel-helpers, babel-plugin-proposal-duplicate-named-capturing-groups-regex, babel-plugin-transform-named-capturing-groups-regex
    • babel-parser
    • babel-helpers, babel-plugin-proposal-duplicate-named-capturing-groups-regex
    • babel-plugin-transform-async-to-generator, babel-plugin-transform-parameters, babel-preset-env

    :house: Internal

    v7.20.0 (2022-10-27)

    :rocket: New Feature

    • babel-compat-data, babel-helper-compilation-targets, babel-preset-env
    • babel-plugin-syntax-typescript
    • babel-generator, babel-parser, babel-plugin-syntax-explicit-resource-management, babel-plugin-transform-block-scoping, babel-plugin-transform-destructuring, babel-standalone, babel-traverse, babel-types
    • babel-generator, babel-parser, babel-plugin-syntax-import-reflection, babel-standalone, babel-types
    • babel-generator, babel-helper-skip-transparent-expression-wrappers, babel-parser, babel-plugin-transform-typescript, babel-traverse, babel-types

    :bug: Bug Fix

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies 
    opened by dependabot[bot] 0
  • build(deps-dev): bump @rollup/plugin-replace from 4.0.0 to 5.0.0

    build(deps-dev): bump @rollup/plugin-replace from 4.0.0 to 5.0.0

    Bumps @rollup/plugin-replace from 4.0.0 to 5.0.0.

    Changelog

    Sourced from @​rollup/plugin-replace's changelog.

    v5.0.0

    2022-10-10

    Breaking Changes

    • fix: prepare for Rollup 3 #1286
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies 
    opened by dependabot[bot] 0
  • build(deps-dev): bump commitizen from 4.2.4 to 4.2.5

    build(deps-dev): bump commitizen from 4.2.4 to 4.2.5

    Bumps commitizen from 4.2.4 to 4.2.5.

    Release notes

    Sourced from commitizen's releases.

    v4.2.5

    4.2.5 (2022-07-17)

    Bug Fixes

    • deps: update all non-major dependencies (69de704)
    • deps: update all non-major dependencies (3c2553f)
    • deps: update dependencies from renovatebot PRs (#862) (64a8ed6)
    • deps: update dependency glob to v7.1.6 (#861) (2505419)
    • deps: update dependency inquirer to v8 (#874) (9c7e863)
    • do not include .nyc_output in published files (#851) (68c377b), closes 4.2.4#d2h-425221 #730
    • fix the "isFunction" utility to match both "asyncFunction"s and "Function"s (#927) (25dc80c), closes #926
    • git-cz.js,staging.js: check for staged files before running prompt (#818) (fdb73cd), closes #785 #585 #785
    Commits
    • 0939910 ci(release): defined a github workflow to release with semantic-release (#923)
    • 757a806 chore(deps): update all non-major dependencies
    • 25dc80c fix: fix the "isFunction" utility to match both "asyncFunction"s and "Functio...
    • fc283fb chore(deps): update dependency semver to v7.3.7
    • c35a3c7 chore(deps): update all non-major dependencies
    • 69de704 fix(deps): update all non-major dependencies
    • e79f3ee chore(deps): update dependency @​babel/core to v7.17.8
    • 69689fb chore(deps): update all non-major dependencies to v7.17.7
    • 3c2553f fix(deps): update all non-major dependencies
    • 4118263 docs: add cz-git commitizen adapter (#905)
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies 
    opened by dependabot[bot] 0
  • build(deps-dev): bump @rollup/plugin-commonjs from 22.0.0 to 23.0.0

    build(deps-dev): bump @rollup/plugin-commonjs from 22.0.0 to 23.0.0

    Bumps @rollup/plugin-commonjs from 22.0.0 to 23.0.0.

    Changelog

    Sourced from @​rollup/plugin-commonjs's changelog.

    v23.0.0

    2022-10-09

    Breaking Changes

    • fix: prepare for Rollup 3 #1300

    v22.0.2

    2022-08-05

    Bugfixes

    • fix: Exclude multi-line template strings from indent (#1229)

    v22.0.1

    2022-06-24

    Bugfixes

    • fix: Only proxy detected commonjs entry points (#1180)
    Commits
    • 7a150cb chore(release): commonjs v23.0.0
    • f56bf9e fix(commonjs): prepare for Rollup 3 (#1300)
    • 69146cd chore(repo): central changes for Rollup 3 updates (#1277)
    • 4e85ed7 chore(all): fix lint issues (#1270)
    • 2483b40 chore(repo): correct READMEs, minimatch to picomatch (#1260)
    • 160959d chore(release): commonjs v22.0.2
    • 54c1a7c fix(commonjs): Exclude multi-line template strings from indent (#1229)
    • 985cf4c chore(release): commonjs v22.0.1
    • 6ba7148 fix(commonjs): Only proxy detected commonjs entry points (#1180)
    • 3bc287c chore(release): commonjs v22.0.0
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies 
    opened by dependabot[bot] 0
  • build(deps-dev): bump lint-staged from 12.4.1 to 13.0.3

    build(deps-dev): bump lint-staged from 12.4.1 to 13.0.3

    Bumps lint-staged from 12.4.1 to 13.0.3.

    Release notes

    Sourced from lint-staged's releases.

    v13.0.3

    13.0.3 (2022-06-24)

    Bug Fixes

    • correctly handle git stash when using MSYS2 (#1178) (0d627a5)

    v13.0.2

    13.0.2 (2022-06-16)

    Bug Fixes

    • use new --diff and --diff-filter options when checking task modifications (1a5a66a)

    v13.0.1

    13.0.1 (2022-06-08)

    Bug Fixes

    • correct spelling of "0 files" (f27f1d4)
    • suppress error from process.kill when killing tasks on failure (f2c6bdd)
    • deps: update [email protected]^0.6.0 to fix screen size error in WSL (1a77e42)
    • ignore "No matching pid found" error (cb8a432)
    • prevent possible race condition when killing tasks on failure (bc92aff)

    Performance Improvements

    • use EventsEmitter instead of setInterval for killing tasks on failure (c508b46)

    v13.0.0

    13.0.0 (2022-06-01)

    Bug Fixes

    Features

    • remove support for Node.js 12 (5fb6df9)

    BREAKING CHANGES

    ... (truncated)

    Commits
    • 0d627a5 fix: correctly handle git stash when using MSYS2 (#1178)
    • 1a5a66a fix: use new --diff and --diff-filter options when checking task modifica...
    • 32806da test: split integration tests into separate files and improve isolation
    • 4384114 refactor: reuse Listr stuff better
    • f27f1d4 fix: correct spelling of "0 files"
    • f2c6bdd fix: suppress error from process.kill when killing tasks on failure
    • c5cec0a docs: add section about task concurrency to README.md
    • 5bf1f18 docs: remove mrm from README.md
    • c508b46 perf: use EventsEmitter instead of setInterval for killing tasks on failure
    • 1a77e42 fix(deps): update [email protected]^0.6.0 to fix screen size error in WSL
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies 
    opened by dependabot[bot] 0
  • build(deps-dev): bump rollup from 2.72.1 to 2.79.1

    build(deps-dev): bump rollup from 2.72.1 to 2.79.1

    Bumps rollup from 2.72.1 to 2.79.1.

    Release notes

    Sourced from rollup's releases.

    v2.79.1

    2022-09-22

    Bug Fixes

    • Avoid massive performance degradation when creating thousands of chunks (#4643)

    Pull Requests

    v2.79.0

    2022-08-31

    Features

    • Add amd.forceJsExtensionForImports to enforce using .js extensions for relative AMD imports (#4607)

    Pull Requests

    v2.78.1

    2022-08-19

    Bug Fixes

    • Avoid inferring "arguments" as name for a default export placeholder variable (#4613)

    Pull Requests

    v2.78.0

    2022-08-14

    Features

    • Support writing plugin hooks as objects with a "handler" property (#4600)
    • Allow changing execution order per plugin hook (#4600)
    • Add flag to execute plugins in async parallel hooks sequentially (#4600)

    Pull Requests

    v2.77.3

    2022-08-11

    ... (truncated)

    Changelog

    Sourced from rollup's changelog.

    2.79.1

    2022-09-22

    Bug Fixes

    • Avoid massive performance degradation when creating thousands of chunks (#4643)

    Pull Requests

    2.79.0

    2022-08-31

    Features

    • Add amd.forceJsExtensionForImports to enforce using .js extensions for relative AMD imports (#4607)

    Pull Requests

    2.78.1

    2022-08-19

    Bug Fixes

    • Avoid inferring "arguments" as name for a default export placeholder variable (#4613)

    Pull Requests

    2.78.0

    2022-08-14

    Features

    • Support writing plugin hooks as objects with a "handler" property (#4600)
    • Allow changing execution order per plugin hook (#4600)
    • Add flag to execute plugins in async parallel hooks sequentially (#4600)

    Pull Requests

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies 
    opened by dependabot[bot] 0
Releases(v2.9.3)
Owner
NativeScript-Vue
A NativeScript plugin for building truly native applications using Vue.js
NativeScript-Vue
Hybrid mobile template built with Ionic Vue using capacitor for native builds

Ionic Vue Mobile Template 03 Hybrid mobile template built with Ionic Vue using c

null 4 Aug 24, 2022
Mobile app development framework and SDK using HTML5 and JavaScript. Create beautiful and performant cross-platform mobile apps. Based on Web Components, and provides bindings for Angular 1, 2, React and Vue.js.

Onsen UI - Cross-Platform Hybrid App and PWA Framework Onsen UI is an open source framework that makes it easy to create native-feeling Progressive We

null 8.7k Nov 29, 2022
A configurable Mobile UI based on Antd Mobile and Vue

A configurable Mobile UI specification and Vue-based implementation.

ladybird-studio 61 Sep 26, 2022
A powerful cross-platform UI toolkit for building native-quality iOS, Android, and Progressive Web Apps with HTML, CSS, and JavaScript.

Ionic Framework Ionic Framework is the open-source mobile app development framework that makes it easy to build top quality native and progressive web

Ionic 48.3k Nov 30, 2022
Sahay-mobileapp - Sahay mobile app built using VueJS and Ionic

A product to help humanity, and India as a country, especially during the novel

Siddhayak 0 Jan 24, 2022
🐡 A mobile UI toolkit designed for financial scenarios, and compatible with multiple platforms based on Vue DSL(Vue 2.0).

Mand [email protected] ?? A mobile UI toolkit designed for financial scenarios, and compatible with multiple platforms based on Vue DSL(Vue 2.0). Webapp Unia

Mand Mobile 11 Jun 24, 2022
A Mobile UI components based on Weui Design and Vue

A Mobile UI components based on Weui Design and Vue Features Support TS Install $ npm install weui-design-vue --save Quickstart in src/main.js import

null 23 Nov 9, 2022
NutUI 3 - 京东风格的轻量级移动端 Vue 组件库 (A Vue.js UI Toolkit for Mobile Web)

NutUI 3 - 京东风格的轻量级移动端 Vue 组件库 (A Vue.js UI Toolkit for Mobile Web)

JDR Design FE 4.8k Nov 20, 2022
Mobile UI Components based on Vue & WeUI

Be Cool with [email protected]^2.3.0 and WeUI. Live Demo >> Sponsors 我们的产品 Requirements 暂未适配 [email protected],请注意。 [email protected]^2.3.0(for .sync modifier) [email protected]^2.0 [email protected]^7.6

Airyland 17.6k Nov 21, 2022
Mobile UI elements for Vue.js

Mint UI Mobile UI elements for Vue 2.0 Homepage Documentation Installation npm i mint-ui -S # for Vue 1.x npm i [email protected] -S Usage Import all compone

饿了么前端 16.5k Nov 22, 2022
Lightweight Mobile UI Components built on Vue

Vant Mobile UI Components built on Vue ?? 文档网站(国内) ?? 文档网站(GitHub) ???? 中文版介绍 Features 65+ Reusable components 1kb Component average size (min+gzip) 9

有赞 20.5k Nov 20, 2022
A fantastic mobile ui lib implement by Vue.

A fantastic mobile ui lib implement by Vue.

DiDi 9k Nov 23, 2022
💰 A mobile UI toolkit, based on Vue.js 2, designed for financial scenarios.

?? A mobile UI toolkit, based on Vue.js 2, designed for financial scenarios.

DiDi 3.3k Nov 23, 2022
Material design mobile component library for Vue3

Material design mobile component library for Vue3

null 3.6k Nov 28, 2022
Ampersand 239 Nov 21, 2022
Capybara : Storefront UI based theme for Vue Storefront

Capybara - Storefront UI based theme for Vue Storefront New default template theme for Vue Storefront, based on Storefront UI. 90% of the Capybara cod

null 2 Nov 2, 2021
Native mobile applications using Vue and NativeScript.

Supporting NativeScript-Vue NativeScript-Vue is an MIT-licensed open source project made possible by our sponsors: and these awesome backers: Tiago Al

NativeScript-Vue 4.9k Nov 26, 2022
Vue Native is a framework to build cross platform native mobile apps using JavaScript

Vue Native Visit our website at vue-native.io or read the official documentation here. Build native mobile apps using Vue Vue Native is a framework to

GeekyAnts 8.4k Nov 22, 2022
TMM is a Linux native game modding tool. it allows to install and depoly mods for Linux native and wine games.

TMM is a Linux native mod manager made with the Tauri toolkit, it can, install, load, remove, and deploy mods for both linux native and wine games.

Mathiew May 116 Nov 23, 2022
Native desktop applications using Vue.js.

Vuido Create native desktop applications for Windows, OS X and Linux using Vue.js. Introduction Vuido is a framework for creating native desktop appli

Michał Męciński 6.1k Nov 21, 2022