Traveliko - Travel with Friends ~ Web application prepared using Google Street View API that allows you to real-time travel with your friends in the same place in street view mode.

Last update: Mar 3, 2022

Traveliko - Travel with Friends!

Open Source Love nodejs javascript vuejs firebase

You can create a room with your friends and travel in street view mode and navigate the map.

screenshot

The application basically allows you to travel through a specific address or by opening the street view from where the user left the pin on the map. When the user switches to the street view, a room is set up and with the room number created, different users act in the same location instantly. Thus, more than one user can stroll on the same street.

Website: https://traveliko.vercel.app/

Installation & Development Setup

  1. Clone Repository

    git clone https://github.com/onlyilkr/traveliko.git
  2. Install packages

    npm install
  3. Go to Firebase Console and set up .env file with your Firebase Realtime Database info

    VUE_APP_FIREBASE_API_KEY=[YOUR_FIREBASE_API_KEY]
    VUE_APP_FIREBASE_AUTH_DOMAIN=[YOUR_FIREBASE_AUTH_DOMAIN]
    VUE_APP_FIREBASE_PROJECT_ID=[YOUR_FIREBASE_PROJECT_ID]
    VUE_APP_FIREBASE_STORAGE_BUCKET=[YOUR_FIREBASE_STORAGE_BUCKET]
    VUE_APP_FIREBASE_MESSAGING_SENDER_ID=[YOUR_FIREBASE_MESSAGING_SENDER_ID]
    VUE_APP_FIREBASE_APP_ID=[YOUR_FIREBASE_APP_ID]
    VUE_APP_FIREBASE_DATABASE_URL=[YOUR_FIREBASE_DATABASE_URL]
    VUE_APP_FIREBASE_MEASUREMENT_ID=[YOUR_FIREBASE_MEASUREMENT_ID]
    
  4. Go to Google Cloud Platform and set up .env file with your Google Maps API Key info

    VUE_APP_GOOGLE_MAPS_API_KEY=[YOUR_GOOGLE_MAPS_API_KEY]
    
  5. Run App

    npm run serve

Meta

İlker Güldalı

github twitter website

Distributed under the Apache license. See LICENSE for more information.

Contributing

  1. Fork it (https://github.com/onlyilkr/traveliko.git)
  2. Create your feature branch (git checkout -b feature/fooBar)
  3. Commit your changes (git commit -am 'Add some fooBar')
  4. Push to the branch (git push origin feature/fooBar)
  5. Create a new Pull Request

GitHub

https://github.com/onlyilkr/traveliko
Comments
  • 1. Bump core-js from 3.12.0 to 3.23.2

    Bumps core-js from 3.12.0 to 3.23.2.

    Changelog

    Sourced from core-js's changelog.

    3.23.2 - 2022.06.21
    • Avoided creation of extra properties for the handling of %TypedArray% constructors in new methods, #1092 (comment)
    • Added Deno 1.23 compat data mapping
    3.23.1 - 2022.06.14
    • Fixed possible error on multiple core-js copies, #1091
    • Added v flag to RegExp.prototype.flags implementation in case if current V8 bugs will not be fixed before this flag implementation
    3.23.0 - 2022.06.14
    • Array find from last moved to the stable ES, according to June 2022 TC39 meeting:
      • Array.prototype.findLast
      • Array.prototype.findLastIndex
      • %TypedArray%.prototype.findLast
      • %TypedArray%.prototype.findLastIndex
    • Methods from the Array grouping proposal renamed, according to June 2022 TC39 meeting:
      • Array.prototype.groupBy -> Array.prototype.group
      • Array.prototype.groupByToMap -> Array.prototype.groupToMap
    • Changed the order of operations in %TypedArray%.prototype.with following proposal-change-array-by-copy/86, according to June 2022 TC39 meeting
    • Decorator Metadata proposal extracted from Decorators proposal as a separate stage 2 proposal, according to March 2022 TC39 meeting, Symbol.metadataKey replaces Symbol.metadata
    • Added Array.prototype.push polyfill with some fixes for modern engines
    • Added Array.prototype.unshift polyfill with some fixes for modern engines
    • Fixed a bug in the order of getting flags in RegExp.prototype.flags in the actual version of V8
    • Fixed property descriptors of some Math and Number constants
    • Added a workaround of V8 ArrayBufferDetaching protector cell invalidation and performance degradation on structuredClone feature detection, one more case of #679
    • Added detection of NodeJS bug in structuredClone that can not clone DOMException (just in case for future versions that will fix other issues)
    • Compat data:
      • Added NodeJS 18.3 compat data mapping
      • Added and fixed Deno 1.22 and 1.21 compat data mapping
      • Added Opera Android 69 compat data mapping
      • Updated Electron 20.0 compat data mapping
    3.22.8 - 2022.06.02
    • Fixed possible multiple call of ToBigInt / ToNumber conversion of the argument passed to %TypedArray%.prototype.fill in V8 ~ Chrome < 59, Safari < 14.1, FF < 55, Edge <=18
    • Fixed some cases of DeletePropertyOrThrow in IE9-
    • Fixed the kind of error (TypeError instead of Error) on incorrect exec result in RegExp.prototype.test polyfill
    • Fixed dependencies of { actual, full, features }/typed-array/at entries
    • Added Electron 20.0 compat data mapping
    • Added iOS Safari 15.5 compat data mapping
    • Refactoring
    3.22.7 - 2022.05.24
    • Added a workaround for V8 ~ Chrome 53 bug with non-writable prototype of some methods, #1083
    3.22.6 - 2022.05.23
    • Fixed possible double call of ToNumber conversion on arguments of Math.{ fround, trunc } polyfills
    • Array.prototype.includes marked as fixed in FF102
    3.22.5 - 2022.05.10
    • Ensured that polyfilled constructors .prototype is non-writable
    • Ensured that polyfilled methods .prototype is not defined

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-21 07:26
  • 2. Bump @vue/cli-plugin-router from 4.5.12 to 5.0.5

    Bumps @vue/cli-plugin-router from 4.5.12 to 5.0.5.

    Release notes

    Sourced from @​vue/cli-plugin-router's releases.

    v5.0.5

    :bug: Bug Fix

    • @vue/cli
      • #7167 fix(upgrade): prevent changing the structure of package.json file during upgrade (@​blzsaa)
    • @vue/cli-service
    • @vue/cli-plugin-e2e-cypress
      • [697bb44] fix: should correctly resolve cypress bin path for Cypress 10 (Note that the project is still created with Cypress 9 by default, but you can upgrade to Cypress 10 on your own now)

    Committers: 3

    v5.0.4

    :bug: Bug Fix

    • @vue/cli-service
    • @vue/cli-shared-utils, @vue/cli-ui
      • 75826d6 fix: replace node-ipc with @achrinza/node-ipc to further secure the dependency chain

    Committers: 1

    v5.0.3

    5.0.3 (2022-03-15)

    :bug: Bug Fix

    • @vue/cli-shared-utils, @vue/cli-ui
      • Lock node-ipc to v9.2.1

    v5.0.2

    :bug: Bug Fix

    Committers: 2

    v5.0.1

    See https://cli.vuejs.org/migrations/migrate-from-v4.html for a complete list of breaking changes from v4.


    v5.0.0 was skipped due to a network failure when releasing the packages.


    ... (truncated)

    Changelog

    Sourced from @​vue/cli-plugin-router's changelog.

    5.0.5 (2022-06-16)

    :bug: Bug Fix

    • @vue/cli
      • #7167 feat(upgrade): prevent changing the structure of package.json file during upgrade (@​blzsaa)
    • @vue/cli-service

    Committers: 3

    5.0.4 (2022-03-22)

    :bug: Bug Fix

    • @vue/cli-service
    • @vue/cli-shared-utils, @vue/cli-ui
      • 75826d6 fix: replace node-ipc with @achrinza/node-ipc to further secure the dependency chain

    Committers: 1

    5.0.3 (2022-03-15)

    :bug: Bug Fix

    • @vue/cli-shared-utils, @vue/cli-ui
      • Lock node-ipc to v9.2.1

    5.0.2 (2022-03-15)

    :bug: Bug Fix

    Committers: 2

    5.0.1 (2022-02-17)

    Same as 5.0.0.

    5.0.0 (2022-02-17)

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-16 07:25
  • 3. Bump @vue/cli-plugin-vuex from 4.5.12 to 5.0.5

    Bumps @vue/cli-plugin-vuex from 4.5.12 to 5.0.5.

    Release notes

    Sourced from @​vue/cli-plugin-vuex's releases.

    v5.0.5

    :bug: Bug Fix

    • @vue/cli
      • #7167 fix(upgrade): prevent changing the structure of package.json file during upgrade (@​blzsaa)
    • @vue/cli-service
    • @vue/cli-plugin-e2e-cypress
      • [697bb44] fix: should correctly resolve cypress bin path for Cypress 10 (Note that the project is still created with Cypress 9 by default, but you can upgrade to Cypress 10 on your own now)

    Committers: 3

    v5.0.4

    :bug: Bug Fix

    • @vue/cli-service
    • @vue/cli-shared-utils, @vue/cli-ui
      • 75826d6 fix: replace node-ipc with @achrinza/node-ipc to further secure the dependency chain

    Committers: 1

    v5.0.3

    5.0.3 (2022-03-15)

    :bug: Bug Fix

    • @vue/cli-shared-utils, @vue/cli-ui
      • Lock node-ipc to v9.2.1

    v5.0.2

    :bug: Bug Fix

    Committers: 2

    v5.0.1

    See https://cli.vuejs.org/migrations/migrate-from-v4.html for a complete list of breaking changes from v4.


    v5.0.0 was skipped due to a network failure when releasing the packages.


    ... (truncated)

    Changelog

    Sourced from @​vue/cli-plugin-vuex's changelog.

    5.0.5 (2022-06-16)

    :bug: Bug Fix

    • @vue/cli
      • #7167 feat(upgrade): prevent changing the structure of package.json file during upgrade (@​blzsaa)
    • @vue/cli-service

    Committers: 3

    5.0.4 (2022-03-22)

    :bug: Bug Fix

    • @vue/cli-service
    • @vue/cli-shared-utils, @vue/cli-ui
      • 75826d6 fix: replace node-ipc with @achrinza/node-ipc to further secure the dependency chain

    Committers: 1

    5.0.3 (2022-03-15)

    :bug: Bug Fix

    • @vue/cli-shared-utils, @vue/cli-ui
      • Lock node-ipc to v9.2.1

    5.0.2 (2022-03-15)

    :bug: Bug Fix

    Committers: 2

    5.0.1 (2022-02-17)

    Same as 5.0.0.

    5.0.0 (2022-02-17)

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-16 07:20
  • 4. Bump core-js from 3.12.0 to 3.23.1

    Bumps core-js from 3.12.0 to 3.23.1.

    Changelog

    Sourced from core-js's changelog.

    3.23.1 - 2022.06.14
    • Fixed possible error on multiple core-js copies, #1091
    • Added v flag to RegExp.prototype.flags implementation in case if current V8 bugs will not be fixed before this flag implementation
    3.23.0 - 2022.06.14
    • Array find from last moved to the stable ES, according to June 2022 TC39 meeting:
      • Array.prototype.findLast
      • Array.prototype.findLastIndex
      • %TypedArray%.prototype.findLast
      • %TypedArray%.prototype.findLastIndex
    • Methods from the Array grouping proposal renamed, according to June 2022 TC39 meeting:
      • Array.prototype.groupBy -> Array.prototype.group
      • Array.prototype.groupByToMap -> Array.prototype.groupToMap
    • Changed the order of operations in %TypedArray%.prototype.with following proposal-change-array-by-copy/86, according to June 2022 TC39 meeting
    • Decorator Metadata proposal extracted from Decorators proposal as a separate stage 2 proposal, according to March 2022 TC39 meeting, Symbol.metadataKey replaces Symbol.metadata
    • Added Array.prototype.push polyfill with some fixes for modern engines
    • Added Array.prototype.unshift polyfill with some fixes for modern engines
    • Fixed a bug in the order of getting flags in RegExp.prototype.flags in the actual version of V8
    • Fixed property descriptors of some Math and Number constants
    • Added a workaround of V8 ArrayBufferDetaching protector cell invalidation and performance degradation on structuredClone feature detection, one more case of #679
    • Added detection of NodeJS bug in structuredClone that can not clone DOMException (just in case for future versions that will fix other issues)
    • Compat data:
      • Added NodeJS 18.3 compat data mapping
      • Added and fixed Deno 1.22 and 1.21 compat data mapping
      • Added Opera Android 69 compat data mapping
      • Updated Electron 20.0 compat data mapping
    3.22.8 - 2022.06.02
    • Fixed possible multiple call of ToBigInt / ToNumber conversion of the argument passed to %TypedArray%.prototype.fill in V8 ~ Chrome < 59, Safari < 14.1, FF < 55, Edge <=18
    • Fixed some cases of DeletePropertyOrThrow in IE9-
    • Fixed the kind of error (TypeError instead of Error) on incorrect exec result in RegExp.prototype.test polyfill
    • Fixed dependencies of { actual, full, features }/typed-array/at entries
    • Added Electron 20.0 compat data mapping
    • Added iOS Safari 15.5 compat data mapping
    • Refactoring
    3.22.7 - 2022.05.24
    • Added a workaround for V8 ~ Chrome 53 bug with non-writable prototype of some methods, #1083
    3.22.6 - 2022.05.23
    • Fixed possible double call of ToNumber conversion on arguments of Math.{ fround, trunc } polyfills
    • Array.prototype.includes marked as fixed in FF102
    3.22.5 - 2022.05.10
    • Ensured that polyfilled constructors .prototype is non-writable
    • Ensured that polyfilled methods .prototype is not defined
    • Added detection and fix of a V8 ~ Chrome <103 bug of struturedClone that returns null if cloned object contains multiple references to one error
    3.22.4 - 2022.05.03
    • Ensured proper .length of polyfilled functions even in compressed code (excepting some ancient engines)

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-15 07:19
  • 5. Bump core-js from 3.12.0 to 3.23.0

    Bumps core-js from 3.12.0 to 3.23.0.

    Changelog

    Sourced from core-js's changelog.

    3.23.0 - 2022.06.14
    • Array find from last moved to the stable ES, according to June 2022 TC39 meeting:
      • Array.prototype.findLast
      • Array.prototype.findLastIndex
      • %TypedArray%.prototype.findLast
      • %TypedArray%.prototype.findLastIndex
    • Methods from the Array grouping proposal renamed, according to June 2022 TC39 meeting:
      • Array.prototype.groupBy -> Array.prototype.group
      • Array.prototype.groupByToMap -> Array.prototype.groupToMap
    • Changed the order of operations in %TypedArray%.prototype.with following proposal-change-array-by-copy/86, according to June 2022 TC39 meeting
    • Decorator Metadata proposal extracted from Decorators proposal as a separate stage 2 proposal, according to March 2022 TC39 meeting, Symbol.metadataKey replaces Symbol.metadata
    • Added Array.prototype.push polyfill with some fixes for modern engines
    • Added Array.prototype.unshift polyfill with some fixes for modern engines
    • Fixed a bug in the order of getting flags in RegExp.prototype.flags in the actual version of V8
    • Fixed property descriptors of some Math and Number constants
    • Added a workaround of V8 ArrayBufferDetaching protector cell invalidation and performance degradation on structuredClone feature detection, one more case of #679
    • Added detection of NodeJS bug in structuredClone that can not clone DOMException (just in case for future versions that will fix other issues)
    • Compat data:
      • Added NodeJS 18.3 compat data mapping
      • Added and fixed Deno 1.22 and 1.21 compat data mapping
      • Added Opera Android 69 compat data mapping
      • Updated Electron 20.0 compat data mapping
    3.22.8 - 2022.06.02
    • Fixed possible multiple call of ToBigInt / ToNumber conversion of the argument passed to %TypedArray%.prototype.fill in V8 ~ Chrome < 59, Safari < 14.1, FF < 55, Edge <=18
    • Fixed some cases of DeletePropertyOrThrow in IE9-
    • Fixed the kind of error (TypeError instead of Error) on incorrect exec result in RegExp.prototype.test polyfill
    • Fixed dependencies of { actual, full, features }/typed-array/at entries
    • Added Electron 20.0 compat data mapping
    • Added iOS Safari 15.5 compat data mapping
    • Refactoring
    3.22.7 - 2022.05.24
    • Added a workaround for V8 ~ Chrome 53 bug with non-writable prototype of some methods, #1083
    3.22.6 - 2022.05.23
    • Fixed possible double call of ToNumber conversion on arguments of Math.{ fround, trunc } polyfills
    • Array.prototype.includes marked as fixed in FF102
    3.22.5 - 2022.05.10
    • Ensured that polyfilled constructors .prototype is non-writable
    • Ensured that polyfilled methods .prototype is not defined
    • Added detection and fix of a V8 ~ Chrome <103 bug of struturedClone that returns null if cloned object contains multiple references to one error
    3.22.4 - 2022.05.03
    • Ensured proper .length of polyfilled functions even in compressed code (excepting some ancient engines)
    • Ensured proper .name of polyfilled accessors (excepting some ancient engines)
    • Ensured proper source / ToString conversion of polyfilled accessors
    • Actualized Rhino compat data
    • Refactoring

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-14 07:21
  • 6. Bump firebase from 8.5.0 to 9.8.3

    Bumps firebase from 8.5.0 to 9.8.3.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-10 07:27
  • 7. Bump sass from 1.32.12 to 1.52.3

    Bumps sass from 1.32.12 to 1.52.3.

    Release notes

    Sourced from sass's releases.

    Dart Sass 1.52.3

    To install Sass 1.52.3, download one of the packages below and add it to your PATH, or see the Sass website for full installation instructions.

    Changes

    • Fix crash when trailing loud comments (/* ... */) appear twice in a row across two different imports which themselves imported the same file each.

    See the full changelog for changes in earlier releases.

    Dart Sass 1.52.2

    To install Sass 1.52.2, download one of the packages below and add it to your PATH, or see the Sass website for full installation instructions.

    Changes

    • Preserve location of trailing loud comments (/* ... */) instead of pushing the comment to the next line.

    See the full changelog for changes in earlier releases.

    Dart Sass 1.52.1

    To install Sass 1.52.1, download one of the packages below and add it to your PATH, or see the Sass website for full installation instructions.

    Changes

    Command Line Interface

    • Fix a bug where --watch mode would close immediately in TTY mode. This was caused by our change to close --watch when stdin was closed outside of TTY mode, which has been reverted for now while we work on a fix.

    See the full changelog for changes in earlier releases.

    Dart Sass 1.52.0

    To install Sass 1.52.0, download one of the packages below and add it to your PATH, or see the Sass website for full installation instructions.

    Changes

    • Add support for arbitrary modifiers at the end of plain CSS imports, in addition to the existing supports() and media queries. Sass now allows any sequence of identifiers of functions after the URL of an import for forwards compatibility with future additions to the CSS spec.

    • Fix an issue where source locations tracked through variable references could potentially become incorrect.

    ... (truncated)

    Changelog

    Sourced from sass's changelog.

    1.52.3

    • Fix crash when trailing loud comments (/* ... */) appear twice in a row across two different imports which themselves imported the same file each.

    1.52.2

    • Preserve location of trailing loud comments (/* ... */) instead of pushing the comment to the next line.

    1.52.1

    Command Line Interface

    • Fix a bug where --watch mode would close immediately in TTY mode. This was caused by our change to close --watch when stdin was closed outside of TTY mode, which has been reverted for now while we work on a fix.

    1.52.0

    • Add support for arbitrary modifiers at the end of plain CSS imports, in addition to the existing supports() and media queries. Sass now allows any sequence of identifiers of functions after the URL of an import for forwards compatibility with future additions to the CSS spec.

    • Fix an issue where source locations tracked through variable references could potentially become incorrect.

    • Fix a bug where a loud comment in the source can break the source map when embedding the sources, when using the command-line interface or the legacy JS API.

    JS API

    • SassNumber.assertUnit() and SassNumber.assertNoUnits() now correctly return the number called on when it passes the assertion.

    1.51.0

    • Potentially breaking change: Change the order of maps returned by map.deep-merge() to match those returned by map.merge(). All keys that appeared in the first map will now be listed first in the same order they appeared in that map, followed by any new keys added from the second map.

    • Improve the string output of some AST nodes in error messages.

    1.50.1

    Embedded Sass

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-09 07:17
  • 8. Bump sass from 1.32.12 to 1.52.2

    Bumps sass from 1.32.12 to 1.52.2.

    Release notes

    Sourced from sass's releases.

    Dart Sass 1.52.2

    To install Sass 1.52.2, download one of the packages below and add it to your PATH, or see the Sass website for full installation instructions.

    Changes

    • Preserve location of trailing loud comments (/* ... */) instead of pushing the comment to the next line.

    See the full changelog for changes in earlier releases.

    Dart Sass 1.52.1

    To install Sass 1.52.1, download one of the packages below and add it to your PATH, or see the Sass website for full installation instructions.

    Changes

    Command Line Interface

    • Fix a bug where --watch mode would close immediately in TTY mode. This was caused by our change to close --watch when stdin was closed outside of TTY mode, which has been reverted for now while we work on a fix.

    See the full changelog for changes in earlier releases.

    Dart Sass 1.52.0

    To install Sass 1.52.0, download one of the packages below and add it to your PATH, or see the Sass website for full installation instructions.

    Changes

    • Add support for arbitrary modifiers at the end of plain CSS imports, in addition to the existing supports() and media queries. Sass now allows any sequence of identifiers of functions after the URL of an import for forwards compatibility with future additions to the CSS spec.

    • Fix an issue where source locations tracked through variable references could potentially become incorrect.

    • Fix a bug where a loud comment in the source can break the source map when embedding the sources, when using the command-line interface or the legacy JS API.

    JS API

    • SassNumber.assertUnit() and SassNumber.assertNoUnits() now correctly return the number called on when it passes the assertion.

    See the full changelog for changes in earlier releases.

    Dart Sass 1.51.0

    To install Sass 1.51.0, download one of the packages below and add it to your PATH, or see the Sass website for full installation instructions.

    ... (truncated)

    Changelog

    Sourced from sass's changelog.

    1.52.2

    • Preserve location of trailing loud comments (/* ... */) instead of pushing the comment to the next line.

    1.52.1

    Command Line Interface

    • Fix a bug where --watch mode would close immediately in TTY mode. This was caused by our change to close --watch when stdin was closed outside of TTY mode, which has been reverted for now while we work on a fix.

    1.52.0

    • Add support for arbitrary modifiers at the end of plain CSS imports, in addition to the existing supports() and media queries. Sass now allows any sequence of identifiers of functions after the URL of an import for forwards compatibility with future additions to the CSS spec.

    • Fix an issue where source locations tracked through variable references could potentially become incorrect.

    • Fix a bug where a loud comment in the source can break the source map when embedding the sources, when using the command-line interface or the legacy JS API.

    JS API

    • SassNumber.assertUnit() and SassNumber.assertNoUnits() now correctly return the number called on when it passes the assertion.

    1.51.0

    • Potentially breaking change: Change the order of maps returned by map.deep-merge() to match those returned by map.merge(). All keys that appeared in the first map will now be listed first in the same order they appeared in that map, followed by any new keys added from the second map.

    • Improve the string output of some AST nodes in error messages.

    1.50.1

    Embedded Sass

    • The JS embedded host and the embedded compiler will now properly avoid resolving imports relative to the current working directory unless '.' is passed as a load path.

    • Fix a bug in the JS embedded host's implementation of the legacy JS API where

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-03 09:11
  • 9. Bump core-js from 3.12.0 to 3.22.8

    Bumps core-js from 3.12.0 to 3.22.8.

    Changelog

    Sourced from core-js's changelog.

    3.22.8 - 2022.06.02
    • Fixed possible multiple call of ToBigInt / ToNumber conversion of the argument passed to %TypedArray%.prototype.fill in V8 ~ Chrome < 59, Safari < 14.1, FF < 55, Edge <=18
    • Fixed some cases of DeletePropertyOrThrow in IE9-
    • Fixed the kind of error (TypeError instead of Error) on incorrect exec result in RegExp.prototype.test polyfill
    • Fixed dependencies of { actual, full, features }/typed-array/at entries
    • Added Electron 20.0 compat data mapping
    • Added iOS Safari 15.5 compat data mapping
    • Refactoring
    3.22.7 - 2022.05.24
    • Added a workaround for V8 ~ Chrome 53 bug with non-writable prototype of some methods, #1083
    3.22.6 - 2022.05.23
    • Fixed possible double call of ToNumber conversion on arguments of Math.{ fround, trunc } polyfills
    • Array.prototype.includes marked as fixed in FF102
    3.22.5 - 2022.05.10
    • Ensured that polyfilled constructors .prototype is non-writable
    • Ensured that polyfilled methods .prototype is not defined
    • Added detection and fix of a V8 ~ Chrome <103 bug of struturedClone that returns null if cloned object contains multiple references to one error
    3.22.4 - 2022.05.03
    • Ensured proper .length of polyfilled functions even in compressed code (excepting some ancient engines)
    • Ensured proper .name of polyfilled accessors (excepting some ancient engines)
    • Ensured proper source / ToString conversion of polyfilled accessors
    • Actualized Rhino compat data
    • Refactoring
    3.22.3 - 2022.04.28
    • Added a fix for FF99+ Array.prototype.includes broken on sparse arrays
    3.22.2 - 2022.04.21
    • Fixed URLSearchParams in IE8- that was broken in the previous release
    • Fixed __lookupGetter__ entries
    3.22.1 - 2022.04.20
    • Improved some cases of RegExp flags handling
    • Prevented experimental warning in NodeJS ~ 18.0 on detection fetch API
    • Added NodeJS 18.0 compat data
    3.22.0 - 2022.04.15
    • Change Array by copy proposal:
      • Moved to Stage 3, March TC39 meeting
      • Disabled forced replacement and added /actual/ entry points for methods from this proposal
      • Array.prototype.toSpliced throws a TypeError instead of RangeError if the result length is more than MAX_SAFE_INTEGER, proposal-change-array-by-copy/70
    • Added some more atob / btoa fixes:
      • NodeJS <17.9 atob does not ignore spaces, node/42530
      • Actual NodeJS atob does not validate encoding, node/42646
      • FF26- implementation does not properly convert argument to string
      • IE / Edge <16 implementation have wrong arity

    ... (truncated)

    Commits
    • 18a2e90 3.22.8
    • b931062 temporarily revert change the order of operations in `%TypedArray%.prototype....
    • 0460543 fix #1086
    • 9fed52d fix some cases of DeletePropertyOrThrow in IE9-
    • 6f9bf9e fix possible multiple call of ToBigInt / ToNumber conversion of the argum...
    • c04e4e1 fix a helper name
    • 7687c2b add iOS Safari 15.5 compat data mapping
    • 3837bf8 some %TypedArray% methods fixes
    • 6870c2a avoid some unnecessary global
    • 373e276 extract doesNonExceededSafeInteger helper
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-02 07:22
  • 10. Bump firebase from 8.5.0 to 9.8.2

    Bumps firebase from 8.5.0 to 9.8.2.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-05-30 07:24
  • 11. Bump core-js from 3.12.0 to 3.22.7

    Bumps core-js from 3.12.0 to 3.22.7.

    Changelog

    Sourced from core-js's changelog.

    3.22.7 - 2022.05.24
    • Added a workaround for V8 ~ Chrome 53 bug with non-writable prototype of some methods, #1083
    3.22.6 - 2022.05.23
    • Fixed possible double call of ToNumber conversion on arguments of Math.{ fround, trunc } polyfills
    • Array.prototype.includes marked as fixed in FF102
    3.22.5 - 2022.05.10
    • Ensured that polyfilled constructors .prototype is non-writable
    • Ensured that polyfilled methods .prototype is not defined
    • Added detection and fix of a V8 ~ Chrome <103 bug of struturedClone that returns null if cloned object contains multiple references to one error
    3.22.4 - 2022.05.03
    • Ensured proper .length of polyfilled functions even in compressed code (excepting some ancient engines)
    • Ensured proper .name of polyfilled accessors (excepting some ancient engines)
    • Ensured proper source / ToString conversion of polyfilled accessors
    • Actualized Rhino compat data
    • Refactoring
    3.22.3 - 2022.04.28
    • Added a fix for FF99+ Array.prototype.includes broken on sparse arrays
    3.22.2 - 2022.04.21
    • Fixed URLSearchParams in IE8- that was broken in the previous release
    • Fixed __lookupGetter__ entries
    3.22.1 - 2022.04.20
    • Improved some cases of RegExp flags handling
    • Prevented experimental warning in NodeJS ~ 18.0 on detection fetch API
    • Added NodeJS 18.0 compat data
    3.22.0 - 2022.04.15
    • Change Array by copy proposal:
      • Moved to Stage 3, March TC39 meeting
      • Disabled forced replacement and added /actual/ entry points for methods from this proposal
      • Array.prototype.toSpliced throws a TypeError instead of RangeError if the result length is more than MAX_SAFE_INTEGER, proposal-change-array-by-copy/70
    • Added some more atob / btoa fixes:
      • NodeJS <17.9 atob does not ignore spaces, node/42530
      • Actual NodeJS atob does not validate encoding, node/42646
      • FF26- implementation does not properly convert argument to string
      • IE / Edge <16 implementation have wrong arity
    • Added /full/ namespace as the replacement for /features/ since it's more descriptive in context of the rest namespaces (/es//stable//actual//full/)
    • Avoided propagation of removed parts of proposals to upper stages. For example, %TypedArray%.prototype.groupBy was removed from the Array grouping proposal a long time ago. We can't completely remove this method since it's a breaking change. But this proposal has been promoted to stage 3 - so the proposal should be promoted without this method, this method should not be available in /actual/ entries - but it should be available in early-stage entries to avoid breakage.
    • Significant internal refactoring and splitting of modules (but without exposing to public API since it will be a breaking change - it will be exposed in the next major version)
    • Bug fixes:
      • Fixed work of non-standard V8 Error features with wrapped Error constructors, #1061
      • null and undefined allowed as the second argument of structuredClone, #1056
    • Tooling:
      • Stabilized proposals are filtered out from the core-js-compat -> core-js-builder -> core-js-bundle output. That mean that if the output contains, for example, es.object.has-own, the legacy reference to it, esnext.object.has-own, no longer added.
      • Aligned modules filters of core-js-builder and core-js-compat, now it's modules and exclude options

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-05-25 07:27
  • 12. Bump core-js from 3.12.0 to 3.23.3

    Bumps core-js from 3.12.0 to 3.23.3.

    Changelog

    Sourced from core-js's changelog.

    3.23.3 - 2022.06.26
    3.23.2 - 2022.06.21
    • Avoided creation of extra properties for the handling of %TypedArray% constructors in new methods, #1092 (comment)
    • Added Deno 1.23 compat data mapping
    3.23.1 - 2022.06.14
    • Fixed possible error on multiple core-js copies, #1091
    • Added v flag to RegExp.prototype.flags implementation in case if current V8 bugs will not be fixed before this flag implementation
    3.23.0 - 2022.06.14
    • Array find from last moved to the stable ES, according to June 2022 TC39 meeting:
      • Array.prototype.findLast
      • Array.prototype.findLastIndex
      • %TypedArray%.prototype.findLast
      • %TypedArray%.prototype.findLastIndex
    • Methods from the Array grouping proposal renamed, according to June 2022 TC39 meeting:
      • Array.prototype.groupBy -> Array.prototype.group
      • Array.prototype.groupByToMap -> Array.prototype.groupToMap
    • Changed the order of operations in %TypedArray%.prototype.with following proposal-change-array-by-copy/86, according to June 2022 TC39 meeting
    • Decorator Metadata proposal extracted from Decorators proposal as a separate stage 2 proposal, according to March 2022 TC39 meeting, Symbol.metadataKey replaces Symbol.metadata
    • Added Array.prototype.push polyfill with some fixes for modern engines
    • Added Array.prototype.unshift polyfill with some fixes for modern engines
    • Fixed a bug in the order of getting flags in RegExp.prototype.flags in the actual version of V8
    • Fixed property descriptors of some Math and Number constants
    • Added a workaround of V8 ArrayBufferDetaching protector cell invalidation and performance degradation on structuredClone feature detection, one more case of #679
    • Added detection of NodeJS bug in structuredClone that can not clone DOMException (just in case for future versions that will fix other issues)
    • Compat data:
      • Added NodeJS 18.3 compat data mapping
      • Added and fixed Deno 1.22 and 1.21 compat data mapping
      • Added Opera Android 69 compat data mapping
      • Updated Electron 20.0 compat data mapping
    3.22.8 - 2022.06.02
    • Fixed possible multiple call of ToBigInt / ToNumber conversion of the argument passed to %TypedArray%.prototype.fill in V8 ~ Chrome < 59, Safari < 14.1, FF < 55, Edge <=18
    • Fixed some cases of DeletePropertyOrThrow in IE9-
    • Fixed the kind of error (TypeError instead of Error) on incorrect exec result in RegExp.prototype.test polyfill
    • Fixed dependencies of { actual, full, features }/typed-array/at entries
    • Added Electron 20.0 compat data mapping
    • Added iOS Safari 15.5 compat data mapping
    • Refactoring
    3.22.7 - 2022.05.24
    • Added a workaround for V8 ~ Chrome 53 bug with non-writable prototype of some methods, #1083
    3.22.6 - 2022.05.23
    • Fixed possible double call of ToNumber conversion on arguments of Math.{ fround, trunc } polyfills
    • Array.prototype.includes marked as fixed in FF102

    ... (truncated)

    Commits
    • adc9970 3.23.3
    • dd3518c simplify conversion
    • cdbd392 detect early implementations of %TypedArray%.prototype.toSpliced
    • 1b7d33d drop an unnecessary option
    • 33568b6 change the order of operations in %TypedArray%.prototype.toSpliced
    • e0e8799 fix regression of some IE8- issues
    • 93598ce update dependencies
    • 075a847 update dependencies
    • ea2d1a4 update dependencies
    • 4c29e0a 3.23.2
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-27 07:24
  • 13. Bump firebase from 8.5.0 to 9.8.4

    Bumps firebase from 8.5.0 to 9.8.4.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-24 08:01
  • 14. Bump sass from 1.32.12 to 1.53.0

    Bumps sass from 1.32.12 to 1.53.0.

    Release notes

    Sourced from sass's releases.

    Dart Sass 1.53.0

    To install Sass 1.53.0, download one of the packages below and add it to your PATH, or see the Sass website for full installation instructions.

    Changes

    • Add support for calling var() with an empty second argument, such as var(--side, ).

    JS API

    • Fix a bug where meta.load-css() would sometimes resolve relative URLs incorrectly when called from a mixin using the legacy JS API.

    Embedded Sass

    • Respect npm's proxy settings when downloading the embedded Sass compiler.

    See the full changelog for changes in earlier releases.

    Dart Sass 1.52.3

    To install Sass 1.52.3, download one of the packages below and add it to your PATH, or see the Sass website for full installation instructions.

    Changes

    • Fix crash when trailing loud comments (/* ... */) appear twice in a row across two different imports which themselves imported the same file each.

    See the full changelog for changes in earlier releases.

    Dart Sass 1.52.2

    To install Sass 1.52.2, download one of the packages below and add it to your PATH, or see the Sass website for full installation instructions.

    Changes

    • Preserve location of trailing loud comments (/* ... */) instead of pushing the comment to the next line.

    See the full changelog for changes in earlier releases.

    Dart Sass 1.52.1

    To install Sass 1.52.1, download one of the packages below and add it to your PATH, or see the Sass website for full installation instructions.

    ... (truncated)

    Changelog

    Sourced from sass's changelog.

    1.53.0

    • Add support for calling var() with an empty second argument, such as var(--side, ).

    JS API

    • Fix a bug where meta.load-css() would sometimes resolve relative URLs incorrectly when called from a mixin using the legacy JS API.

    Embedded Sass

    • Respect npm's proxy settings when downloading the embedded Sass compiler.

    1.52.3

    • Fix crash when trailing loud comments (/* ... */) appear twice in a row across two different imports which themselves imported the same file each.

    1.52.2

    • Preserve location of trailing loud comments (/* ... */) instead of pushing the comment to the next line.

    1.52.1

    Command Line Interface

    • Fix a bug where --watch mode would close immediately in TTY mode. This was caused by our change to close --watch when stdin was closed outside of TTY mode, which has been reverted for now while we work on a fix.

    1.52.0

    • Add support for arbitrary modifiers at the end of plain CSS imports, in addition to the existing supports() and media queries. Sass now allows any sequence of identifiers of functions after the URL of an import for forwards compatibility with future additions to the CSS spec.

    • Fix an issue where source locations tracked through variable references could potentially become incorrect.

    • Fix a bug where a loud comment in the source can break the source map when embedding the sources, when using the command-line interface or the legacy JS API.

    JS API

    • SassNumber.assertUnit() and SassNumber.assertNoUnits() now correctly return the number called on when it passes the assertion.

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-23 10:20
  • 15. Bump @vue/cli-plugin-router from 4.5.12 to 5.0.6

    Bumps @vue/cli-plugin-router from 4.5.12 to 5.0.6.

    Release notes

    Sourced from @​vue/cli-plugin-router's releases.

    v5.0.6

    Fix compatibility with the upcoming Vue 2.7 (currently in alpha) and Vue Loader 15.10 (currently in beta).

    In Vue 2.7, vue-template-compiler is no longer a required peer dependency. Rather, there's a new export under the main package as vue/compiler-sfc.

    v5.0.5

    :bug: Bug Fix

    • @vue/cli
      • #7167 fix(upgrade): prevent changing the structure of package.json file during upgrade (@​blzsaa)
    • @vue/cli-service
    • @vue/cli-plugin-e2e-cypress
      • [697bb44] fix: should correctly resolve cypress bin path for Cypress 10 (Note that the project is still created with Cypress 9 by default, but you can upgrade to Cypress 10 on your own now)

    Committers: 3

    v5.0.4

    :bug: Bug Fix

    • @vue/cli-service
    • @vue/cli-shared-utils, @vue/cli-ui
      • 75826d6 fix: replace node-ipc with @achrinza/node-ipc to further secure the dependency chain

    Committers: 1

    v5.0.3

    5.0.3 (2022-03-15)

    :bug: Bug Fix

    • @vue/cli-shared-utils, @vue/cli-ui
      • Lock node-ipc to v9.2.1

    v5.0.2

    :bug: Bug Fix

    Committers: 2

    v5.0.1

    See https://cli.vuejs.org/migrations/migrate-from-v4.html for a complete list of breaking changes from v4.

    ... (truncated)

    Changelog

    Sourced from @​vue/cli-plugin-router's changelog.

    5.0.5 (2022-06-16)

    :bug: Bug Fix

    • @vue/cli
      • #7167 feat(upgrade): prevent changing the structure of package.json file during upgrade (@​blzsaa)
    • @vue/cli-service

    Committers: 3

    5.0.4 (2022-03-22)

    :bug: Bug Fix

    • @vue/cli-service
    • @vue/cli-shared-utils, @vue/cli-ui
      • 75826d6 fix: replace node-ipc with @achrinza/node-ipc to further secure the dependency chain

    Committers: 1

    5.0.3 (2022-03-15)

    :bug: Bug Fix

    • @vue/cli-shared-utils, @vue/cli-ui
      • Lock node-ipc to v9.2.1

    5.0.2 (2022-03-15)

    :bug: Bug Fix

    Committers: 2

    5.0.1 (2022-02-17)

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-17 07:24
  • 16. Bump @vue/cli-plugin-vuex from 4.5.12 to 5.0.6

    Bumps @vue/cli-plugin-vuex from 4.5.12 to 5.0.6.

    Release notes

    Sourced from @​vue/cli-plugin-vuex's releases.

    v5.0.6

    Fix compatibility with the upcoming Vue 2.7 (currently in alpha) and Vue Loader 15.10 (currently in beta).

    In Vue 2.7, vue-template-compiler is no longer a required peer dependency. Rather, there's a new export under the main package as vue/compiler-sfc.

    v5.0.5

    :bug: Bug Fix

    • @vue/cli
      • #7167 fix(upgrade): prevent changing the structure of package.json file during upgrade (@​blzsaa)
    • @vue/cli-service
    • @vue/cli-plugin-e2e-cypress
      • [697bb44] fix: should correctly resolve cypress bin path for Cypress 10 (Note that the project is still created with Cypress 9 by default, but you can upgrade to Cypress 10 on your own now)

    Committers: 3

    v5.0.4

    :bug: Bug Fix

    • @vue/cli-service
    • @vue/cli-shared-utils, @vue/cli-ui
      • 75826d6 fix: replace node-ipc with @achrinza/node-ipc to further secure the dependency chain

    Committers: 1

    v5.0.3

    5.0.3 (2022-03-15)

    :bug: Bug Fix

    • @vue/cli-shared-utils, @vue/cli-ui
      • Lock node-ipc to v9.2.1

    v5.0.2

    :bug: Bug Fix

    Committers: 2

    v5.0.1

    See https://cli.vuejs.org/migrations/migrate-from-v4.html for a complete list of breaking changes from v4.

    ... (truncated)

    Changelog

    Sourced from @​vue/cli-plugin-vuex's changelog.

    5.0.5 (2022-06-16)

    :bug: Bug Fix

    • @vue/cli
      • #7167 feat(upgrade): prevent changing the structure of package.json file during upgrade (@​blzsaa)
    • @vue/cli-service

    Committers: 3

    5.0.4 (2022-03-22)

    :bug: Bug Fix

    • @vue/cli-service
    • @vue/cli-shared-utils, @vue/cli-ui
      • 75826d6 fix: replace node-ipc with @achrinza/node-ipc to further secure the dependency chain

    Committers: 1

    5.0.3 (2022-03-15)

    :bug: Bug Fix

    • @vue/cli-shared-utils, @vue/cli-ui
      • Lock node-ipc to v9.2.1

    5.0.2 (2022-03-15)

    :bug: Bug Fix

    Committers: 2

    5.0.1 (2022-02-17)

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    Reviewed by dependabot[bot] at 2022-06-17 07:20
This component allows you to display custom HTML content on the map using Overlay
This component allows you to display custom HTML content on the map using Overlay

vue3-gmap-custom-marker This component allows you to display custom HTML content on the map using Overlay. This component is an update (a fork) from e

Apr 1, 2022
Integrate Google Maps in your Vue application
Integrate Google Maps in your Vue application

vue-googlemaps Integrate Google Maps in your Vue application in a "Vue-way". This library is Work In Progress. More components will be available in th

Jun 27, 2022
A wrapper component for consuming Google Maps API built on top of VueJs v2.

A wrapper component for consuming Google Maps API built on top of VueJs v2. Fork of the popular vue-google-maps plugin.

Jun 30, 2022
A quick way to start a web map application with Vue.js using MapLibre GL JS.
A quick way to start a web map application with Vue.js using MapLibre GL JS.

Vue.js map using MapLibre GL JS A quick way to start a web map application with Vue.js using MapLibre GL JS. A simple fullscreen map application is us

May 28, 2022
A set of composable components for easy use of Google Maps in your Vue 3 projects.

A set of composable components for easy use of Google Maps in your Vue 3 projects.

Jun 24, 2022
Using Google Maps with Vue.js

stores-map Project setup npm install Compiles and hot-reloads for development npm run serve Compiles and minifies for production npm run build Run

Apr 22, 2022
Geolocation field & map block: All you need for a map on your website
Geolocation field & map block: All you need for a map on your website

Geolocation field & map block: All you need for a map on your website

May 2, 2022
Integrate Azure Maps in your Vue application

Vue Azure Maps Vue Azure Maps is a library for Vue.js that integrates Azure Maps. It offers several Vue components out of the box and supports custom

May 19, 2022
Google maps component for vue with 2-way data binding

CONTRIBUTORS NEEDED! It's been increasingly difficult for me to make time to maintain this project. My projects at work have also gradually migrated a

Jul 3, 2022
a simple component to generate an static google map
a simple component to generate an static google map

vue-static-map a simple component to generate an static google map Google Documentation Demo SandBox JSBin example Requirements Vue 2.X.X Usage Instal

May 17, 2022
A lightweight Google Maps plugin for Vue
A lightweight Google Maps plugin for Vue

x5-gmaps (Live Demo) This is a lightweight Google Maps plugin for Vue. Samples/examples/tutorials Tutorial creating a COVID Heatmap Address Autocomple

Apr 22, 2022
vue google map custom marker component
vue google map custom marker component

vue2-gmap-custom-marker This component allows you to display custom HTML content on the map using Overlay. This component is an adaptation of the Goog

May 17, 2022
Google maps component for vue with 2-way data binding

vue-google-maps Demo: Demo in production Showcase with a lot of features Presentation If you want to write google map this way : <map :center="{lat:

May 25, 2022
Reactive Vue 3 components for Google maps

Vue 3 Google maps Components Set of mostly used Google Maps components for Vue.js. Why this library exists? We heavily use Google Maps in our projects

Jul 3, 2022
📍 Vue composable for Google Maps Places Autocomplete.

v-use-places-autocomplete ?? Vue composable for Google Maps Places Autocomplete. Though not a fork, this composable is fully inspired by react-google-

Jun 28, 2022
Render every single road in any city, The data is fetched from OpenStreetMap using overpass API.
Render every single road in any city, The data is fetched from OpenStreetMap using overpass API.

Render every single road in any city, The data is fetched from OpenStreetMap using overpass API.

Jun 28, 2022
Web map Vue components with the power of OpenLayers

VueLayers Web map Vue components with the power of OpenLayers Overview VueLayers is components library that brings the powerful OpenLayers API to the

Jun 21, 2022
Web map Vue 3.x components with the power of OpenLayers
Web map Vue 3.x components with the power of OpenLayers

vue3-openlayers Web map Vue components with the power of OpenLayers Overview vue3-openlayers is components library that brings the powerful OpenLayers

Jun 24, 2022
Kartobuilder - a php package for the laravel framework that works with the inertia jetstream stack to build your own map

Kartobuilder is a php package for the laravel framework that works with the inertia jetstream stack to build your own map.

May 3, 2022