Tornado v2 | User Interface Framework

Overview

Welcome to Tornado UI v2

Tornado is an Open Source Framework for Forntend and UI/UX Designers made with love from a designer to designers the Main Goal of this framework is to make web design more simple and providing the best performance and easy to control elements Builded With Sass and TypeScript for Easy Customizing.


browser support

v31+ v49+ v10+ v35+ v12+ v11+

Documentation

looking for Documentation Visit Tornado UI v2


Before You Start

Before you start working with the framework you must know that this framework ment to be a complete work enviroment not just including the production css/js files so if you want to understand what exactly happening and use it in the right way continue reading the docementation.

Installation

in order to install Tornado env you can use npm or you can use Git CLI from the Following Commands.

====== Git CLI Clone =====
git clone https://github.com/EngCode/Tornado-UI-v2.git

====== NPM Install ======
npm install tornado-ui

after that you will need to install Node.JS and SASS the Ruby version for compiling the source files.

Quick CDN Links

====== Tornado CSS [LTR] =====
https://unpkg.com/[email protected]/dist/css/tornado.css

====== Tornado CSS [RTL] =====
https://unpkg.com/[email protected]/dist/css/tornado-rtl.css

====== Tornado [ICONS] CSS =====
https://unpkg.com/[email protected]/dist/css/tornado-icons.css

====== Tornado JS =====
https://unpkg.com/[email protected]/dist/js/tornado.min.js

Lateast Update V2.6.0 Finale || 1/1/2021

#01 - [new] New Utlilites Classes
#02 - [fix] Navigation Menu - Megamenu
#03 - [fix] Counter Type Fixed
#04 - [fix] Form Repeaters [Advanced Controls]
#05 - [fix] Form Rating Hover
#06 - [fix] First View Activate [Lazyloading, VP Animations].
#-- - []
#-- - [fix] [Repeater, Advanced Select, Dropdowns]
#-- - [upgrade] Manual Mode any TS Utilities 

Ex-Update V2.5. Super 🦸‍♂️ Tornado || 07/2020

#01 - [new] Convert all Javascript from Babel to Typescript
#02 - [new] React Components for all UI Elements
#03 - [new] Seperate Icons Font CSS from Tornado CSS.
#04 - [new] JS Event Date/Time Counter Down
#05 - [new] Dynamic Backgrounds Lazy Loading Added
#06 - [new] images lazyloading added
#07 - [new] CSS Variables for Design Options
#08 - [new] Form Control Validation In Realtime
#09 - [new] Form UI SASS Rewrite and JS Upgrade
#10 - [new] Form Advanced Select
#11 - [new] Form Advanced File Uploader
#12 - [new] Form Repeater Functionality
#13 - [new] Form Rating Stars
#14 - [new] Buttons new Themes Added
#15 - [new] TNS Slider Method and UI Components
#16 - [new] Data Tables Creation Method
#17 - [new] Tabs TypeScript Method
#18 - [new] Popup TypeScript Method
#19 - [new] Images Lightbox Component and Method
#20 - [new] Circle and Radial Progress Components
#21 - [new] Tornado Design Options Method
#22 - [new] Tornado Theme Switcher Method
#23 - [doc] Documenting Typescript Methods
#24 - [fix] JS Dynamic Page Direction for WP-Admin
#25 - [Deprecated] Remove Form Lined Theme

Credits


License

Copyright (c) 2016-present, Abdullah Ramadan. Licensed under the terms of the MIT License.

Comments
  • Bump lodash from 4.17.15 to 4.17.19 in /DesignTemplates/tornado-icons

    Bump lodash from 4.17.15 to 4.17.19 in /DesignTemplates/tornado-icons

    ⚠️ Dependabot is rebasing this PR ⚠️

    Rebasing might not happen immediately, so don't worry if this takes some time.

    Note: if you make any changes to this PR yourself, they will take precedence over the rebase.


    Bumps lodash from 4.17.15 to 4.17.19.

    Release notes

    Sourced from lodash's releases.

    4.17.16

    Commits
    Maintainer changes

    This version was pushed to npm by mathias, a new releaser for lodash since your current version.


    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 7
  • Bump scss-tokenizer and node-sass

    Bump scss-tokenizer and node-sass

    Bumps scss-tokenizer to 0.4.3 and updates ancestor dependency node-sass. These dependencies need to be updated together.

    Updates scss-tokenizer from 0.3.0 to 0.4.3

    Release notes

    Sourced from scss-tokenizer's releases.

    v0.4.3

    What's Changed

    New Contributors

    Full Changelog: https://github.com/sasstools/scss-tokenizer/compare/v0.4.2...v0.4.3

    v0.4.2

    Misc

    • Restore prepublishOnly npm script (@​xzyfer, ae79d74)

    v0.4.1

    Fixes

    v0.4.0

    Fixes

    Tests

    • Add basic test coverage to interpolant tokenization (@​xzyfer, #20)

    Dependencies

    Misc

    • TravisCI now tests all supported Node versions
    • Commit package-lock.json
    Commits

    Updates node-sass from 7.0.1 to 7.0.3

    Release notes

    Sourced from node-sass's releases.

    v7.0.3

    Dependencies

    • Bump sass-graph from 4.0.0 to ^4.0.1

    Supported Environments

    OS Architecture Node
    Windows x86 & x64 12, 14, 16, 17
    OSX x64 12, 14, 16, 17
    Linux* x64 12, 14, 16, 17
    Alpine Linux x64 12, 14, 16, 17
    FreeBSD i386 amd64 12, 14

    *Linux support refers to major distributions like Ubuntu, and Debian

    v7.0.2

    This release has been unpublished

    Commits

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 1
  • Bump ansi-html and webpack-dev-server

    Bump ansi-html and webpack-dev-server

    Removes ansi-html. It's no longer used after updating ancestor dependency webpack-dev-server. These dependencies need to be updated together.

    Removes ansi-html

    Updates webpack-dev-server from 4.0.0 to 4.11.1

    Release notes

    Sourced from webpack-dev-server's releases.

    v4.11.1

    4.11.1 (2022-09-19)

    Bug Fixes

    • respect client.logging option for all logs (#4572) (375835c)

    v4.11.0

    4.11.0 (2022-09-07)

    Features

    • make allowedHosts accept localhost subdomains by default (#4357) (0a33e6a)

    Bug Fixes

    v4.10.1

    4.10.1 (2022-08-29)

    Bug Fixes

    v4.10.0

    4.10.0 (2022-08-10)

    Features

    • allow to configure more client options via resource URL (#4274) (216e3cb)

    Bug Fixes

    • response correctly when receive an OPTIONS request (#4185) (2b3b7e0)

    v4.9.3

    4.9.3 (2022-06-29)

    Bug Fixes

    • avoid creation unnecessary stream for static sockjs file (#4482) (049b153)
    • history-api-fallback now supports HEAD requests and handles them the same as GET (8936082)

    ... (truncated)

    Changelog

    Sourced from webpack-dev-server's changelog.

    4.11.1 (2022-09-19)

    Bug Fixes

    • respect client.logging option for all logs (#4572) (375835c)

    4.11.0 (2022-09-07)

    Features

    • make allowedHosts accept localhost subdomains by default (#4357) (0a33e6a)

    Bug Fixes

    4.10.1 (2022-08-29)

    Bug Fixes

    4.10.0 (2022-08-10)

    Features

    • allow to configure more client options via resource URL (#4274) (216e3cb)

    Bug Fixes

    • response correctly when receive an OPTIONS request (#4185) (2b3b7e0)

    4.9.3 (2022-06-29)

    Bug Fixes

    • avoid creation unnecessary stream for static sockjs file (#4482) (049b153)
    • history-api-fallback now supports HEAD requests and handles them the same as GET (8936082)

    4.9.2 (2022-06-06)

    Bug Fixes

    ... (truncated)

    Commits
    • 418e932 chore(release): 4.11.1
    • 375835c fix: respect client.logging option for all logs (#4572)
    • ef2f9e9 chore: fix examples for open target not working (#4575)
    • 7da7336 ci: workflow security
    • 5d4b347 chore(deps-dev): bump core-js from 3.25.1 to 3.25.2 (#4574)
    • 87072c7 chore(deps-dev): bump @​types/node-forge from 1.0.4 to 1.0.5 (#4571)
    • 28f6381 chore(deps-dev): bump @​babel/plugin-transform-runtime (#4567)
    • 595003b chore(deps-dev): bump @​babel/core from 7.19.0 to 7.19.1 (#4568)
    • 67acc2e chore(deps-dev): bump @​babel/eslint-parser from 7.18.9 to 7.19.1 (#4569)
    • ad2dcc5 chore(deps-dev): bump @​babel/preset-env from 7.19.0 to 7.19.1 (#4570)
    • Additional commits viewable in compare view

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 1
  • Bump loader-utils from 1.4.0 to 1.4.2

    Bump loader-utils from 1.4.0 to 1.4.2

    Bumps loader-utils from 1.4.0 to 1.4.2.

    Release notes

    Sourced from loader-utils's releases.

    v1.4.2

    1.4.2 (2022-11-11)

    Bug Fixes

    v1.4.1

    1.4.1 (2022-11-07)

    Bug Fixes

    Changelog

    Sourced from loader-utils's changelog.

    1.4.2 (2022-11-11)

    Bug Fixes

    1.4.1 (2022-11-07)

    Bug Fixes

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 1
  • Bump async from 2.6.3 to 2.6.4

    Bump async from 2.6.3 to 2.6.4

    Bumps async from 2.6.3 to 2.6.4.

    Changelog

    Sourced from async's changelog.

    v2.6.4

    • Fix potential prototype pollution exploit (#1828)
    Commits
    Maintainer changes

    This version was pushed to npm by hargasinski, a new releaser for async since your current version.


    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 1
  • Bump minimist from 1.2.5 to 1.2.6

    Bump minimist from 1.2.5 to 1.2.6

    Bumps minimist from 1.2.5 to 1.2.6.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 1
  • Bump node-forge from 0.10.0 to 1.3.0

    Bump node-forge from 0.10.0 to 1.3.0

    Bumps node-forge from 0.10.0 to 1.3.0.

    Changelog

    Sourced from node-forge's changelog.

    1.3.0 - 2022-03-17

    Security

    • Three RSA PKCS#1 v1.5 signature verification issues were reported by Moosa Yahyazadeh ([email protected]).
    • HIGH: Leniency in checking digestAlgorithm structure can lead to signature forgery.
    • HIGH: Failing to check tailing garbage bytes can lead to signature forgery.
    • MEDIUM: Leniency in checking type octet.
      • DigestInfo is not properly checked for proper ASN.1 structure. This can lead to successful verification with signatures that contain invalid structures but a valid digest.
      • CVE ID: CVE-2022-24773
      • GHSA ID: GHSA-2r2c-g63r-vccr

    Fixed

    • [asn1] Add fallback to pretty print invalid UTF8 data.
    • [asn1] fromDer is now more strict and will default to ensuring all input bytes are parsed or throw an error. A new option parseAllBytes can disable this behavior.
      • NOTE: The previous behavior is being changed since it can lead to security issues with crafted inputs. It is possible that code doing custom DER parsing may need to adapt to this new behavior and optional flag.
    • [rsa] Add and use a validator to check for proper structure of parsed ASN.1 RSASSA-PKCS-v1_5 DigestInfo data. Additionally check that the hash algorithm identifier is a known value from RFC 8017 PKCS1-v1-5DigestAlgorithms. An invalid DigestInfo or algorithm identifier will now throw an error.
      • NOTE: The previous lenient behavior is being changed to be more strict since it could lead to security issues with crafted inputs. It is possible that code may have to handle the errors from these stricter checks.

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 1
  • Bump follow-redirects from 1.14.4 to 1.14.8

    Bump follow-redirects from 1.14.4 to 1.14.8

    Bumps follow-redirects from 1.14.4 to 1.14.8.

    Commits
    • 3d81dc3 Release version 1.14.8 of the npm package.
    • 62e546a Drop confidential headers across schemes.
    • 2ede36d Release version 1.14.7 of the npm package.
    • 8b347cb Drop Cookie header across domains.
    • 6f5029a Release version 1.14.6 of the npm package.
    • af706be Ignore null headers.
    • d01ab7a Release version 1.14.5 of the npm package.
    • 40052ea Make compatible with Node 17.
    • 86f7572 Fix: clear internal timer on request abort to avoid leakage
    • 2e1eaf0 Keep Authorization header on subdomain redirects.
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 1
  • Bump ajv from 6.12.2 to 6.12.6

    Bump ajv from 6.12.2 to 6.12.6

    Bumps ajv from 6.12.2 to 6.12.6.

    Release notes

    Sourced from ajv's releases.

    v6.12.6

    Fix performance issue of "url" format.

    v6.12.5

    Fix uri scheme validation (@​ChALkeR). Fix boolean schemas with strictKeywords option (#1270)

    v6.12.4

    Fix: coercion of one-item arrays to scalar that should fail validation (failing example).

    v6.12.3

    Pass schema object to processCode function Option for strictNumbers (@​issacgerges, #1128) Fixed vulnerability related to untrusted schemas (CVE-2020-15366)

    Commits
    • fe59143 6.12.6
    • d580d3e Merge pull request #1298 from ajv-validator/fix-url
    • fd36389 fix: regular expression for "url" format
    • 490e34c docs: link to v7-beta branch
    • 9cd93a1 docs: note about v7 in readme
    • 877d286 Merge pull request #1262 from b4h0-c4t/refactor-opt-object-type
    • f1c8e45 6.12.5
    • 764035e Merge branch 'ChALkeR-chalker/fix-comma'
    • 3798160 Merge branch 'chalker/fix-comma' of git://github.com/ChALkeR/ajv into ChALkeR...
    • a3c7eba Merge branch 'refactor-opt-object-type' of github.com:b4h0-c4t/ajv into refac...
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 1
  • Bump node-sass from 4.14.1 to 7.0.0

    Bump node-sass from 4.14.1 to 7.0.0

    Bumps node-sass from 4.14.1 to 7.0.0.

    Release notes

    Sourced from node-sass's releases.

    v7.0.0

    Breaking changes

    Features

    Dependencies

    Community

    • Remove double word "support" from documentation (@​pzrq, #3159)

    Misc

    Supported Environments

    OS Architecture Node
    Windows x86 & x64 12, 14, 16, 17
    OSX x64 12, 14, 16, 17
    Linux* x64 12, 14, 16, 17
    Alpine Linux x64 12, 14, 16, 17
    FreeBSD i386 amd64 12, 14

    *Linux support refers to major distributions like Ubuntu, and Debian

    v6.0.1

    Dependencies

    Misc

    Supported Environments

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 1
  • Bump follow-redirects from 1.14.4 to 1.14.7

    Bump follow-redirects from 1.14.4 to 1.14.7

    Bumps follow-redirects from 1.14.4 to 1.14.7.

    Commits
    • 2ede36d Release version 1.14.7 of the npm package.
    • 8b347cb Drop Cookie header across domains.
    • 6f5029a Release version 1.14.6 of the npm package.
    • af706be Ignore null headers.
    • d01ab7a Release version 1.14.5 of the npm package.
    • 40052ea Make compatible with Node 17.
    • 86f7572 Fix: clear internal timer on request abort to avoid leakage
    • 2e1eaf0 Keep Authorization header on subdomain redirects.
    • 2ad9e82 Carry over Host header on relative redirects (#172)
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 1
  • [Snyk] Upgrade node-sass from 7.0.1 to 7.0.3

    [Snyk] Upgrade node-sass from 7.0.1 to 7.0.3

    Snyk has created this PR to upgrade node-sass from 7.0.1 to 7.0.3.

    :information_source: Keep your dependencies up-to-date. This makes it easier to fix existing vulnerabilities and to more quickly identify and fix newly disclosed vulnerabilities when they affect your project.


    • The recommended version is 2 versions ahead of your current version.
    • The recommended version was released 4 months ago, on 2022-09-08.

    The recommended version fixes:

    Severity | Issue | PriorityScore (*) | Exploit Maturity | :-------------------------:|:-------------------------|-------------------------|:------------------------- | Regular Expression Denial of Service (ReDoS)
    SNYK-JS-SCSSTOKENIZER-2339884 | 479/1000
    Why? Has a fix available, CVSS 5.3 | No Known Exploit

    (*) Note that the real score may have changed since the PR was raised.

    Release notes
    Package name: node-sass
    • 7.0.3 - 2022-09-08

      Dependencies

      • Bump sass-graph from 4.0.0 to ^4.0.1

      Supported Environments

      OS Architecture Node
      Windows x86 & x64 12, 14, 16, 17
      OSX x64 12, 14, 16, 17
      Linux* x64 12, 14, 16, 17
      Alpine Linux x64 12, 14, 16, 17
      FreeBSD i386 amd64 12, 14

      *Linux support refers to major distributions like Ubuntu, and Debian

    • 7.0.2 - 2022-09-08

      This release has been unpublished

    • 7.0.1 - 2021-12-27

      Dependencies

      • Bump node-gyp from 7.1.2 to 8.4.1
      • Bump sass-graph from 2.2.5 to 4.0.0

      Supported Environments

      OS Architecture Node
      Windows x86 & x64 12, 14, 16, 17
      OSX x64 12, 14, 16, 17
      Linux* x64 12, 14, 16, 17
      Alpine Linux x64 12, 14, 16, 17
      FreeBSD i386 amd64 12, 14

      *Linux support refers to major distributions like Ubuntu, and Debian

    from node-sass GitHub release notes
    Commit messages
    Package name: node-sass

    Compare


    Note: You are seeing this because you or someone else with access to this repository has authorized Snyk to open upgrade PRs.

    For more information:

    🧐 View latest project report

    🛠 Adjust upgrade PR settings

    🔕 Ignore this dependency or unsubscribe from future upgrade PRs

    opened by snyk-bot 0
  • [Snyk] Upgrade webpack-dev-server from 4.0.0 to 4.11.1

    [Snyk] Upgrade webpack-dev-server from 4.0.0 to 4.11.1

    Snyk has created this PR to upgrade webpack-dev-server from 4.0.0 to 4.11.1.

    :information_source: Keep your dependencies up-to-date. This makes it easier to fix existing vulnerabilities and to more quickly identify and fix newly disclosed vulnerabilities when they affect your project.


    • The recommended version is 24 versions ahead of your current version.
    • The recommended version was released 4 months ago, on 2022-09-19.

    The recommended version fixes:

    Severity | Issue | PriorityScore (*) | Exploit Maturity | :-------------------------:|:-------------------------|-------------------------|:------------------------- | Improper Verification of Cryptographic Signature
    SNYK-JS-NODEFORGE-2430339 | 579/1000
    Why? Has a fix available, CVSS 7.3 | No Known Exploit | Regular Expression Denial of Service (ReDoS)
    SNYK-JS-ANSIHTML-1296849 | 579/1000
    Why? Has a fix available, CVSS 7.3 | Proof of Concept | Improper Verification of Cryptographic Signature
    SNYK-JS-NODEFORGE-2430341 | 579/1000
    Why? Has a fix available, CVSS 7.3 | No Known Exploit | Improper Verification of Cryptographic Signature
    SNYK-JS-NODEFORGE-2430337 | 579/1000
    Why? Has a fix available, CVSS 7.3 | No Known Exploit | Prototype Pollution
    SNYK-JS-NODEFORGE-2331908 | 579/1000
    Why? Has a fix available, CVSS 7.3 | No Known Exploit | Open Redirect
    SNYK-JS-NODEFORGE-2330875 | 579/1000
    Why? Has a fix available, CVSS 7.3 | Proof of Concept

    (*) Note that the real score may have changed since the PR was raised.

    Release notes
    Package name: webpack-dev-server
    • 4.11.1 - 2022-09-19

      4.11.1 (2022-09-19)

      Bug Fixes

      • respect client.logging option for all logs (#4572) (375835c)
    • 4.11.0 - 2022-09-07

      4.11.0 (2022-09-07)

      Features

      • make allowedHosts accept localhost subdomains by default (#4357) (0a33e6a)

      Bug Fixes

    • 4.10.1 - 2022-08-29

      4.10.1 (2022-08-29)

      Bug Fixes

    • 4.10.0 - 2022-08-10

      4.10.0 (2022-08-10)

      Features

      • allow to configure more client options via resource URL (#4274) (216e3cb)

      Bug Fixes

      • response correctly when receive an OPTIONS request (#4185) (2b3b7e0)
    • 4.9.3 - 2022-06-29

      4.9.3 (2022-06-29)

      Bug Fixes

      • avoid creation unnecessary stream for static sockjs file (#4482) (049b153)
      • history-api-fallback now supports HEAD requests and handles them the same as GET (8936082)
    • 4.9.2 - 2022-06-06

      4.9.2 (2022-06-06)

      Bug Fixes

      • add @ types/serve-static to dependencies (#4468) (af83deb)
    • 4.9.1 - 2022-05-31

      4.9.1 (2022-05-31)

      Bug Fixes

    • 4.9.0 - 2022-05-04

      4.9.0 (2022-05-04)

      Features

      • support Trusted Types for client overlay (#4404) (8132e1d)

      Bug Fixes

      • ie11 runtime (#4403) (256d5fb)
      • replace portfinder with custom implementation and fix security problem (#4384) (eea50f3)
      • use the host in options to check if port is available (#4385) (a10c7cf)
    • 4.8.1 - 2022-04-06

      4.8.1 (2022-04-06)

      Bug Fixes

    • 4.8.0 - 2022-04-05

      4.8.0 (2022-04-05)

      Features

      Bug Fixes

      • update description for --no-client-reconnect (#4248) (317648d)
      • update description for --no-client (#4250) (c3b6690)
      • update description for --no-history-api-fallback (#4277) (d63a0a2)
      • update negated descriptions for more options (#4287) (c64bd94)
      • update schema to have negatedDescription only for type boolean (#4280) (fcf8e8e)
    • 4.7.4 - 2022-02-02
    • 4.7.3 - 2022-01-11
    • 4.7.2 - 2021-12-29
    • 4.7.1 - 2021-12-22
    • 4.7.0 - 2021-12-21
    • 4.6.0 - 2021-11-25
    • 4.5.0 - 2021-11-13
    • 4.4.0 - 2021-10-27
    • 4.3.1 - 2021-10-04
    • 4.3.0 - 2021-09-25
    • 4.2.1 - 2021-09-13
    • 4.2.0 - 2021-09-09
    • 4.1.1 - 2021-09-07
    • 4.1.0 - 2021-08-31
    • 4.0.0 - 2021-08-18
    from webpack-dev-server GitHub release notes
    Commit messages
    Package name: webpack-dev-server
    • 418e932 chore(release): 4.11.1
    • 375835c fix: respect `client.logging` option for all logs (#4572)
    • ef2f9e9 chore: fix examples for open target not working (#4575)
    • 7da7336 ci: workflow security
    • 5d4b347 chore(deps-dev): bump core-js from 3.25.1 to 3.25.2 (#4574)
    • 87072c7 chore(deps-dev): bump @ types/node-forge from 1.0.4 to 1.0.5 (#4571)
    • 28f6381 chore(deps-dev): bump @ babel/plugin-transform-runtime (#4567)
    • 595003b chore(deps-dev): bump @ babel/core from 7.19.0 to 7.19.1 (#4568)
    • 67acc2e chore(deps-dev): bump @ babel/eslint-parser from 7.18.9 to 7.19.1 (#4569)
    • ad2dcc5 chore(deps-dev): bump @ babel/preset-env from 7.19.0 to 7.19.1 (#4570)
    • a1704e0 chore(deps): bump @ types/express from 4.17.13 to 4.17.14 (#4565)
    • 9480ce4 chore(deps-dev): bump eslint from 8.23.0 to 8.23.1 (#4564)
    • d67b1a9 chore: update `selfsigned` package (#4563)
    • 3c8d5ee chore(deps-dev): bump core-js from 3.25.0 to 3.25.1 (#4561)
    • 76bc4a5 chore(deps-dev): bump typescript from 4.8.2 to 4.8.3 (#4562)
    • 8abb295 chore(release): 4.11.0
    • 984af02 fix: auto reply to OPTIONS requests only when unhandled (#4559)
    • 85dcb31 chore(deps-dev): bump @ babel/core from 7.18.13 to 7.19.0 (#4557)
    • fe058dc chore(deps-dev): bump @ babel/preset-env from 7.18.10 to 7.19.0 (#4558)
    • 1368d1d chore(deps-dev): bump @ babel/runtime from 7.18.9 to 7.19.0 (#4556)
    • 0a33e6a feat: make allowedHosts accept localhost subdomains by default (#4357)
    • 088a318 chore(deps-dev): bump marked from 4.0.19 to 4.1.0 (#4553)
    • 45ed9bd chore(deps): bump bonjour-service from 1.0.13 to 1.0.14 (#4554)
    • eb997bb chore(release): 4.10.1

    Compare


    Note: You are seeing this because you or someone else with access to this repository has authorized Snyk to open upgrade PRs.

    For more information:

    🧐 View latest project report

    🛠 Adjust upgrade PR settings

    🔕 Ignore this dependency or unsubscribe from future upgrade PRs

    opened by snyk-bot 0
Releases(2.5.0)
  • 2.5.0(Jan 12, 2021)

    Update V2.5.☯ Super 🦸‍♂️ Tornado || 07/2020

    #01 - [new] Convert all Javascript from Babel to Typescript #02 - [new] React Components for all UI Elements #03 - [new] Seperate Icons Font CSS from Tornado CSS. #04 - [new] JS Event Date/Time Counter Down #05 - [new] Dynamic Backgrounds Lazy Loading Added #06 - [new] images lazyloading added #07 - [new] CSS Variables for Design Options #08 - [new] Form Control Validation In Realtime #09 - [new] Form UI SASS Rewrite and JS Upgrade #10 - [new] Form Advanced Select #11 - [new] Form Advanced File Uploader #12 - [new] Form Repeater Functionality #13 - [new] Form Rating Stars #14 - [new] Buttons new Themes Added #15 - [new] TNS Slider Method and UI Components #16 - [new] Data Tables Creation Method #17 - [new] Tabs TypeScript Method #18 - [new] Popup TypeScript Method #19 - [new] Images Lightbox Component and Method #20 - [new] Circle and Radial Progress Components #21 - [new] Tornado Design Options Method #22 - [new] Tornado Theme Switcher Method #23 - [doc] Documenting Typescript Methods #24 - [fix] JS Dynamic Page Direction for WP-Admin #25 - [Deprecated] Remove Lined Theme Form #26 - [doc] Documenting React Components

    Source code(tar.gz)
    Source code(zip)
  • 2.1.0(Dec 1, 2019)

    ================> Change Log <================== 01 - [new] Upgrade Components into Mixins and Refactor Tornado Icons 02 - [new] Breadcrumb Theme Mixin 03 - [Doc] Documented All CSS Utlities 04 - [new] Adding Margin/Padding Utlities 05 - [new] Improve Grid CSS Utlities 06 - [Fix] Form Validation Message Fix 07 - [new] Redesign Tornado Icons [+1800 icons] 08 - [new] New Animations Pack Set 09 - [update] improve ALL JS Siblings(); Functions 10 - [update] Improve JS ParentsUntil(); Function 11 - [new] Adding JS Slide Up and Slide Down && Slide Toggle Functions. 12 - [Fix] Collapse Effect Fix With Slide Toggle. 13 - [third party] TinySlider Added [Custom RTL Support] 14 - [Deprecated] Glide.jS 15 - [Deprecated] Helvatica Arabic Fonts 16 - [Deprecated] Old Tornado Icons Font 17 - [Fix] Allow Node Element In Live Event Listener 18 - [new] JS getHeight(); Function Added. 19 - [update] JS Accourdion // Mobile Menu // Nested Menu Dropdowns With Slide Effects 20 - [Fix] Form Controls With Icons Validation Style Fix.

    Source code(tar.gz)
    Source code(zip)
  • 2.0.8(Jul 26, 2019)

    Changelog 06/2019 Components Mixins

    #01 - Documented Responsive Query Mixins. #02 - Adding Form Controls Themes Mixin #03 - Improve Responsive Menus Mixins #04 - Adding Extra Small Responsive Mixin #05 - More Coloring Helpers Added #06 - Adding Mobile Menu Theme Mixin #07 - Adding Header/Navbar Theme Mixin #08 - ViewPort Animations Fix

    Source code(tar.gz)
    Source code(zip)
Owner
Abdullah Ramadan
i'm a Web Full-Stack Designer working in the field since 2010.
Abdullah Ramadan
Google interface with Vue.js

Google Vue Screenshot Project setup npm install Compiles and hot-reloads for development npm run serve Compiles and minifies for production npm run

Lucas 9 Oct 5, 2022
Interface for your UUID fields, in JSON repeater for example

Interface for your UUID fields, in JSON repeater for example

null 15 Nov 5, 2022
Chat App - Project slicing design UI to real interface uisng Vue JS and Tailwind

Chat App - Project slicing design UI to real interface uisng Vue JS and Tailwind

Oka R. Abdillah 35 Nov 30, 2022
an ad admin web, with vue, bootstrap, user auth, uploader and WYSIWYG editor in iframe.

vuetest this project is for mandarin(中文) only VUE TEST BY Sjerrys file uploader, user auth, text editor, bootstrap stuff. can be use with any kind of

3000 20 Nov 24, 2022
🤓 This is a simple SPA built using Koa as the backend, Vue as the first frontend, and React as the second frontend. Features MySQL integration, user authentication, CRUD note actions, and Vuex store modules.

Koa-Vue-Notes-Web This is a simple SPA built using Koa as the backend, Vue as the first frontend, and React as the second frontend. Frontend Vue GitHu

John Datserakis 198 Sep 19, 2022
Build a mult-user blogging app with Supabase and Nuxt.js

Building a Multi-User Blogging App with Nuxt and Supabase This project goes along with the blog post featured on CSS Tricks. Running the project To ge

Nader Dabit 60 Nov 5, 2022
Multi step form that guides the user through checkout process and collects data using GitHub's API

Multi step form that guides the user through checkout process and collects data using GitHub's API

Kevin Martínez Montero 13 Dec 16, 2022
A demo website based on framework Bulma (css) & vuejs (JS)

Introduction My first hands on experience on learning the css library Bulma & JS Framework VueJS. This demo website is a way to test out the features

Faisal Ali 48 Nov 24, 2022
A Twitter Clone using VueJS, Quasar Framework and Firebase

A Twitter Clone using VueJS, Quasar Framework and Firebase

Sans Bhatia 6 Nov 9, 2022
Portfolio template using VueJs framework.

A personal portfolio with Vue JS framework

mahy mohab 21 Oct 29, 2022
🍭 A minimalistic framework for demonstrating your Vue components

vue-play A minimalistic framework for demonstrating your Vue components, inspired by react-storybook. Table of Contents Getting Started Writing Scenar

null 979 Dec 17, 2022
Vue-weather - This is a web application made using a vue js Framework which displays the weather according to the city.

vue-weather Project setup yarn install Compiles and hot-reloads for development yarn serve Compiles and minifies for production yarn build Lints an

Jeriel Mbiedou 0 Jan 3, 2022
Aplicação desenvolvida com o framework Vue.js que consome a API https://pokeapi.co. Feita para fins de estudos. 😊

# pokedex-vue ## Project setup ``` yarn install ``` ### Compiles and hot-reloads for development ``` yarn serve ``` ### Compiles and minifies for p

Igor Xavier 0 May 24, 2022
Portfolio template using VueJs framework, CosmicJS API and Bootstrap

VueJS portfolio template Portfolio template using VueJs framework, CosmicJS API and Bootstrap Live demo with my personnal data here ! Table of Content

null 7 Dec 24, 2022
Professional enterprise application with Vue Composition API, Multi-Module Design, Data Processing Flow and Friendly User Interface.

Vue Admin Next Professional enterprise application with Vue Composition API, Multi-Module Design, Data Processing Flow, and Friendly User Interface. N

FE Next 130 Sep 26, 2022
In this project I cloned the user interface of Windows using Vue.js. Each folder in it represents a GitHub repository.

In this project I cloned the user interface of Windows using Vue.js. Each folder in it represents a GitHub repository.

Mehmet Sağır 74 Nov 21, 2022
A FLINT client, written in Vue, to provide an awesome user interface for configuring simulations using the FLINT.Cloud APIs.

FLINT UI A FLINT client, written in Vue, to provide an awesome user interface for configuring simulations using the FLINT.Cloud APIs Table of Contents

moja global 48 Dec 28, 2022
💙 A simple but consistent user interface made for Vue

Vi-Ui Read the documentation Install: Using NPM: npm install --save vue-vi-ui Or the CDN: <script src="https://unpkg.com/vue-vi-ui/dist/vi-ui.min.js">

Vitta 42 Jul 17, 2022
Ory Kratos Vue3 / Vite with Typescript User Interface Reference Implementation

Ory Kratos Vue3 / Vite with Typescript User Interface Reference Implementation This repository contains a reference implementation for Ory Kratos' in

Tim 21 Jan 1, 2023
A clone of the YouTube user interface in nuxt.js

youtube-ui-clone Warning ! This project is a clone of the YouTube user interface. I am not responsible for any misuse of the code. Build Setup # insta

null 3 Feb 28, 2022